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1 Introduction 

This Step-by-step training guide relates to the fixed link across the Sound (Øresund) 

between Denmark and Sweden. 

 

 
 
Figure 1.1 Øresund, Denmark 

 

1.1 Background 

In 1994 the construction of a fixed link between Copenhagen (Denmark) and Malmö 

(Sweden) as a combined tunnel, bridge and reclamation project commenced. Severe 

environmental constraints were enforced to ensure that the environment of the Baltic Sea 

remains unaffected by the link. These constraints implied that the blocking of the 

uncompensated design of the link should be down to 0.5 %, and similarly maximum 

spillage and dredging volumes had been enforced. To meet the environmental constraints 

and to monitor the construction work a major monitoring programme was set-up. The 

monitoring programme included more than 40 hydrographic stations collecting water level, 

salinity, temperature and current data. In addition intensive field campaigns were 

conducted to supplement the fixed stations with ship-based ADCP measurements and 

CTD profiles. The baseline monitoring programme was launched in 1992 and continued 

into this century.  

 

By virtue of the natural hydrographic variability in Øresund the blocking of the link can 

only be assessed by means of a numerical model.  

 

Amongst the comprehensive data sets from the monitoring programme, which form a 

unique basis for modelling, a three-month period was selected as 'design' period such 

that it reflected the natural variability of Øresund. The design period was used in the 

detailed planning and optimisation of the link, and to define the compensation dredging 

volumes, which were required to reach a so-called Zero Solution. 
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1.2 Objective 

The objective of this Step-by-step training guide is to set-up both a MIKE 21 Flow Model 

with Flexible Mesh (MIKE 21 Flow Model FM), and a MIKE 3 Flow Model FM for Øresund 

from scratch and to calibrate the model to a satisfactory level. 

 

Attempts have been made to make this exercise as realistic as possible although some 

short cuts have been made with respect to the data input. This mainly relates to quality 

assurance and pre-processing of raw data to bring it into a format readily accepted by the 

MIKE Zero software. Depending on the amount and quality of the data sets this can be a 

tedious, time consuming but indispensable process. For this example guide the 'raw' data 

has been provided as standard ASCII text files. 

 

The files used in this Step-by-step training guide are a part of the installation and located 

in the default installation folders: 

 

.\Examples\MIKE_21\FlowModel_FM\HD\Oresund 

 

.\Examples\MIKE_3\FlowModel_FM\HD\Oresund 

 

You should install the examples from the MIKE Zero start page in your own folder. 

 

Please note that all future references made in this Step-by-step guide to files in the 

examples are made relative to the main folders holding the examples. 

 

User Guides and Manuals can be accessed via the MIKE Zero Documentation Index in 

the start menu. 

 

If you are already familiar with importing data into MIKE Zero format files, you do not have 

to generate all the MIKE Zero input parameters yourself from the included raw data. All 

the MIKE Zero input parameter files needed to run the example are included and the 

simulation can start immediately if you want. 
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2 Creating the Computational Mesh 

Creation of the Computational Mesh typically requires numerous modifications of the data 

set, so instead of explaining every mouse click in this phase, the main considerations and 

methods are explained.  

 

The mesh file couples water depths with different geographical positions and contains the 

following information: 

 

1. Computational grid 

2. Water depths 

3. Boundary information 

 

Creation of the mesh file is a very important task in the modelling process. 

 

Please also see the User Guide for the MIKE Zero Mesh Generator, which can be 

accessed via the MIKE Zero Documentation Index in the start menu: 

 

MIKE Zero Pre- and Postprocessing, Generic Editors and Viewers, User Guide 

 

2.1 General Considerations before Creating a Computational Mesh 

The bathymetry and mesh file should 

 

1. describe the water depths in the model area 

2. allow model results with a desired accuracy  

3. give model simulation times acceptable to the user 

 

To obtain this, you should aim at a mesh 

 

1. with triangles without small angles (the perfect mesh has equilateral triangles) 

2. with smooth boundaries 

3. with high resolutions in areas of special interest 

4. based on valid xyz data 

 

Large angles and high resolutions in a mesh are contradicting with the need for short 

simulation times, so the modeller must compromise his choice of triangulation between 

these two factors. 

 

The resolution of the mesh, combined with the water depths and chosen time-step 

governs the Courant numbers in a model set-up. The maximum Courant number shall be 

less than 0.5. So the simulation times dependency on the triangulation of the mesh, 

relates not only to the number of nodes in the mesh, but also the resulting Courant 

numbers. As a result of this, the effect on simulation time of a fine resolution at deep 

water can be relatively high compared to a high resolution at shallow water.  

 

 

 

2.2 Creating the Øresund Computational Mesh 

A chart of the area of interest in this example is shown in Figure 2.1. It covers the Sound 

between Denmark and Sweden. Based on a chart (e.g. from MIKE C-map), xyz data for 
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shorelines and water depths can be generated. In this example xyz data for shorelines 

and water depths have already been generated. See Figure 2.14. 

 

 
 
Figure 2.1 Chart covering the area of interest: Øresund, the Sound between Denmark and 

Sweden 
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2.2.1 Creating a mdf- file from the raw xyz data 

The mesh file containing information about water depths and mesh is created with the 

Mesh Generator tool in MIKE Zero. First you should start the Mesh Generator 

(File→New→ File→Mesh Generator). See Figure 2.2. 

 

After starting the Mesh Generator you should specify the projection system as UTM and 

the zone as 33 for the working area. See Figure 2.3.  

 

 
 
Figure 2.2 Starting the Mesh Generator tool in MIKE Zero 

 

 

 
 
Figure 2.3 Defining the projection of the work space 

 

 

The resulting working area is shown in Figure 2.4. 
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Figure 2.4 The work space as it appears in the Mesh Generator after choosing projection and 

before adding xyz data 

 

 

Import digitised shoreline data from an ASCII file (Data→Import Boundary →Open XYZ 

file: land.xyz). See Figure 2.5. 

 

 
 
Figure 2.5 Import digitised shoreline data 

 

 

Remember to convert from geographical co-ordinates: Choose Longitude/Latitude after 

importing shoreline date. See Figure 2.6. 
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Figure 2.6 Import digitised shoreline data 

 

The resulting workspace with the imported shoreline data will appear in a so-called Mesh 

Definition File (mdf-file) as shown in Figure 2.7. 

 

 
 
Figure 2.7 The mdf-file as it appears in the Mesh Generator after importing shoreline xyz data 
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The next step is to transform the raw data set, into a data set from which the selected 

domain can be triangulated.  

 

2.2.2 Adjusting the boundary data into a domain that can be triangulated 

This task should result in a file with boundary- and water boundaries (the green arcs) - 

forming a closed domain that can be triangulated. 

 

Start by deleting the shoreline vertices and nodes (the red and blue points) that are not 

part of the shoreline of the area that you want to include in the bathymetry. This includes 

the nodes on land that you see in Figure 2.7.  

 

Define a northern and southern boundary between Denmark and Sweden by adding arcs 

between 'Danish' nodes and 'Swedish' nodes. The boundaries should be placed near the 

co-ordinates for the boundary measurements given in Table 2.1.  

 

Mark the North Boundary arc and choose properties. Set the arc attribute to 2 for the 

northern boundary. Mark 3 for the southern boundary arc. See Figure 2.8 and Figure 2.9.. 

These attributes are used for the model system to distinguish between the different 

boundary types in the mesh: the North Boundary (attribute 2) and the South Boundary 

(attribute 3). The land/water boundary (attribute 1) is automatically set by the Mesh 

Generator. 

 

 
Table 2.1 Measured water level data 

 

 

Station 

 

Data File 

Position 

Easting 

(m) 

Northing 

(m) 

WL13 Viken waterlevel_viken.txt 349744 6224518 

WL14 Hornbæk waterlevel_hornbaek.txt 341811 6219382 

WL19 Skanør waterlevel_skanor.txt 362748 6143316 

WL20 Rødvig waterlevel_rodvig.txt 333191 6126049 
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Figure 2.8 Selecting the arc for the northern boundary (purple arc) for editing properties (right click with mouse) 

 

 

 

 
 
Figure 2.9 Editing the northern boundary arc properties 

 

Now you have a closed area that can be triangulated, but first you should go through and 

smooth all the shorelines. It should be noted that the triangulation of the domain starts 

from the boundary polygon, thus the number of elements generated by the triangulation 

process are very dependent of the number of nodes and vertices on the shoreline. 

 

You can use the tool for redistributing the vertices along an arc to form a more uniform 

shoreline. In areas of special interest you can redistribute the vertices along the land 

boundary with a shorter distance between them. You might consider not including the 

bathymetry in inner harbours and lagoons, if they do not have significant effect on the 

results in the areas, where you do have interest. 
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After editing all the shorelines you might end up with an mdf-file similar to the one found in 

this example called: oresund.mdf. See Figure 2.10. Use this file for the further work with 

this example. 

 

2.2.3 Triangulation of the domain 

The next step is to triangulate the domain. First you mark the closed areas (islands) that 

should not be triangulated as polygons (green marks). 

 

 
 
Figure 2.10 The mdf-file as it appears in the Mesh Generator after modifying Boundary xyz data 

to form a closed area surrounded by boundaries ready for triangulation 
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Try to make the first triangulation (Mesh→Generate Mesh). Use the triangulation option 

settings as in Figure 2.11. You can see that in this example, the area of interest has a 

higher resolution than the rest of the mesh. You might also consider refining the mesh in 

specific areas. You can do that by adding a polygon in the area of interest and giving the 

polygon local properties (add green mark in polygon and right click the mark for defining 

its properties).  

 

 
 
Figure 2.11 The triangulation options as they are set in this example 

 

 

After the triangulation you can use a tool for smoothing the mesh (Mesh→Smooth Mesh). 

In this example the mesh has been smoothed 100 times. The resulting mesh will look as 

in Figure 2.12.  

 

First import the xyz-file containing the water depths (Data→Manage Scatter 

Data→Add→water.xyz. Specify projection as Long/Lat for the 1993 data and UTM 33 for 

the 1997 data. The ASCII files are found in the folders: 

 

.\Data\1993\Ascii\water.xyz (for MIKE 21 modelling) 

 

.\Data\1997\Ascii\water.xyz (for MIKE 3 modelling) 
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Figure 2.12 The mesh as it appears in the Mesh Generator after triangulation and smoothing 100 

times. The triangulation options allow a maximum area of 1500000 m2, a minimum 
angle of 30 degrees, and maximum of 6000 nodes. Local triangulation options are 
given in polygons around the areas of interest. 

 

 

Afterwards you have to interpolate the water depths in the appropriate xyz data file into 

the mesh: water.xyz (Mesh→Interpolate). See Figure 2.13.  

 

Please note that the water depths are different in the MIKE 21 FM example and the MIKE 

3 FM example, because they cover two different years, so the morphology has changed. 

The resulting mdf-file for the MIKE 21 bathymetry for 1993 will look as in Figure 2.15. 
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Figure 2.13 Interpolating water depths into the domain from imported XYZ file  

 

 

 
 
Figure 2.14 ASCII file describing the depth at specified geographical positions (Longitude, 

Latitude and Depth). Please note that if MIKE C-map is used you are not allowed to 
view the data in a text editor because the data is encrypted 
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Figure 2.15 The mesh as it appears in the Mesh Generator after interpolating water depth xyz 

data into the mesh 

 

 

Now you are ready to export the data set into a mesh file that can be used in MIKE 21 & 

MIKE 3 Flow Model FM (Mesh→Export Mesh). Save the file as oresund.mesh. 
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You can view (and edit) the resulting mesh file in the Data Viewer (Figure 2.16) or view it 

in MIKE Animator Plus (Figure 2.17). 

 

 
 
Figure 2.16 The Øresund mesh file as it appears in the Data Viewer 
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Figure 2.17 The Øresund mesh as it can be presented with the MIKE Animator Plus tool 
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3 Creating the Input Parameters to the MIKE 21 Flow Model FM 

Before the MIKE 21 Flow Model FM can be set up, the input data must be generated from 

the measurements. Measurements for 1993 exist for  

 

• Water levels at the boundaries 

• Wind at Kastrup Airport (Copenhagen, Denmark) 

 

Preparation of input data is made by using various tools in MIKE Zero. Therefore 

reference is also made to the MIKE Zero User Guide, which can be accessed via the 

MIKE Zero Documentation Index in the start menu: 

 

MIKE Zero Pre- and Postprocessing, Generic Editors and Viewers, User Guide 

 

3.1 Generate Water Level Boundary Conditions 

Measured water level recordings from four stations located near the open model 

boundaries are available for the Øresund model, see Figure 3.1. 

 

Hornbæk
Viken

Rødvig

Skanor

 
 
Figure 3.1 Map showing the water level stations at the open boundaries: Hornbæk, Viken, 

Skanör, and Rødvig  
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The Øresund model is forced with water level boundaries. The water level measurements 

indicate that the variations along the boundaries are significant, so the water level 

boundaries should be specified as line series (dfs1 type data file) containing an 

interpolation between the two measurements at each boundary. 

 

In the following, two line series (dfs1 type data file) with water level variations will be 

created on basis of measured recordings from four stations on two boundaries. The 

locations of the four stations are listed in Table 2.1 

 

3.1.1 Importing measured water levels to time series file 

Open the Time Series Editor in MIKE Zero (File→New→ File→Time Series), see  

Figure 3.2.  

 

 
 
Figure 3.2 Starting the Time Series Editor in MIKE Zero 

 

 

Select the ASCII template. Open the text file waterlevel_hornbaek.txt shown in Figure 3.3. 

Change the time description to 'Equidistant Calendar Axis' and press OK, see Figure 3.4. 

Then right click on the generated data in the Time Series Editor and select properties, see 

Figure 3.5. Change the item type to 'Water Level', see Figure 3.6, and finally, save the 

data in waterlevel_hornbaek.dfs0.  

 

Repeat these steps for the remaining three stations. 

 

Please note that time series must have equidistant time steps in the present version of 

MIKE 21 & MIKE 3 Flow Model FM. That means that if the raw data have time gaps 

without measurements, the gaps in the raw data must be filled (e.g. by interpolation) 

before importing it. 
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Figure 3.3 ASCII file with water level recordings from Station Hornbæk 

 

 
 
Figure 3.4 Time Series Editor: Import from ascii 
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Figure 3.5 Time Series Editor with imported Water Levels from Station 1: Hornbæk 

 

 

 
 
Figure 3.6 Time Series Properties 
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To make a plot of the water level time series open the Plot Composer in MIKE Zero, see 

Figure 3.7. Select 'plot' → 'insert a new plot object' and select 'Time Series Plot' (see 

Figure 3.8).  

 

 
 
Figure 3.7 Starting the Plot Composer in MIKE Zero 

 

 

 
 
Figure 3.8 Insert a new Plot Object as Time Series in Plot Composer 
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Add the actual time series file to the Plot Composer by clicking   and selecting the file, 

see Figure 3.9. It is possible to add more than one time series to the same plot. In the 

Time Series Plot Properties dialogue it is possible to change some of the properties for 

the plot, such as colours, etc. (see Figure 3.10). 

 

 
 
Figure 3.9 Selection of time series files in the Plot Composer 
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Figure 3.10 Plot Composer Time Series Plot Properties dialogue for selecting time series files and 

adjusting scales, curves, etc. 

 

 

Figure 3.11 and Figure 3.12 show the measured water levels at the two boundaries. 
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Figure 3.11 Combined time series at the North Boundary, Stations 1 and 2: Hornbæk and Viken 

 

 
 
Figure 3.12 Combined time series at the South Boundary, Stations 3 and 4: Skanör and Rødvig 

 

3.1.2 Creating boundary conditions 

The next step is to create line series from the generated time series. Load the Profile 

Series in MIKE Zero and select 'Blank ...', see Figure 3.13.  

 

Fill in the required information as shown in Figure 3.14: 

 

North Boundary 

• Start date 1993-12-02 00:00:00 

• Time step: 1800s  

• No. of time steps: 577  

• No. of grid points: 2  

• Grid Step: 9200m (width of boundary, actually not necessary, because MIKE 21 & 

MIKE 3 Flow Model FM interpolates the line series to the boundary nodes without 

respect to this distance, see the MIKE 21 and MIKE 3 Flow Model FM User Guides: 

 

- MIKE 21 Flow Model FM, Hydrodynamic Module, User Guide 

- MIKE 3 Flow Model FM, Hydrodynamic Module, User Guide 
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Figure 3.13 Starting the Profile Series Editor in MIKE Zero 

 

 

 
 
Figure 3.14 Profile Series Properties 
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Load Station Hornbæk (waterlevel_hornbaek.dfs0) and copy and paste the water levels to 

the profile Series Editor at point 0. Next load Station Viken (waterlevel_viken.dfs0) and 

copy and paste the levels into point 1 (see Figure 3.15). Save the profile series as 

waterlevel_north.dfs1 (see Figure 3.16). 

 

 
 
Figure 3.15 Copying water levels from Station 1 (Hornbæk) into the Profile Series Editor (Ctrl V) 

 

 

 
 
Figure 3.16 Water level line series at the North Boundary 

 

 

Repeat the same step with the southern boundary with the similar information except the 

grid step and using the recorded water levels at Station Rødvig (waterlevel_rodvig.dfs0) 

and Station Skanör (waterlevel_skanor.dfs0) and save the resulting file as 

waterlevel_south.dfs1. 
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South Boundary 

• Start date 1993-12-02 00:00:00 

• Time step: 1800s  

• No. of time steps: 577  

• No. of grid points: 2 

• Grid Step: 33500m (actually not necessary, because MIKE 21 & MIKE 3 Flow Model 

FM interpolates the line series to the boundary nodes without respect to this 

distance) 

 

3.2 Initial Conditions 

The initial surface level is calculated as a mean level between the northern and the 

southern boundary at the beginning of the simulation. Load the two boundary files and 

approximate a mean level at the start of the simulation. We will use –0.37 m.  

 

3.3 Wind Forcing 

Wind recordings from Kastrup Airport will form the wind forcing as time series constant in 

space. Load the time series editor and import the ASCII file 'wind_kastrup.txt' with 

equidistant calendar axis. Save the file in 'wind_kastrup.dfs0'. Time series of the wind 

speed and direction is shown in Figure 3.17. 

 

A more descriptive presentation of the wind can be given as a wind-speed (or wind-rose) 

diagram. Start the 'Plot Composer' insert a new plot object, and select 'Wind/Current Rose 

Plot' and then select properties and select the newly created file 'wind_kastrup.dfs0' and 

change the properties of the plot as you prefer with respect to appearance (colours, etc.). 

The result is shown in Figure 3.18. 

 

 
 
Figure 3.17 ASCII file with wind speed and direction from Kastrup Airport 
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Figure 3.17 Wind speed and direction from Kastrup Airport as it can be illustrated in the Plot 

Composer (Time Series Direction plot control) 

 
 

 
 
Figure 3.18 Wind rose from Kastrup Airport as it can be illustrated in the Plot Composer and 

South Boundary 
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4 Creating the Input Parameters to the MIKE 3 Flow Model FM 

Before the MIKE 3 Flow Model FM can be set up, the input data must be generated from 

the measurements. Measurements for 19971 exist for  

 
1. Water levels at the boundaries 
2. Salinity at the boundaries 
3. Temperature at the boundaries 
4. Wind at Ven 

 

Preparation of input data is made by using various tools in MIKE Zero. Therefore 

reference is also made to the MIKE Zero User Guide, which can be accessed via the 

MIKE Zero Documentation Index in the start menu: 

 

MIKE Zero Pre- and Postprocessing, Generic Editors and Viewers, User Guide 

 

4.1 Generate Boundary Conditions 

4.1.1 Water levels 

Measured water level recordings from four stations located near the open model 

boundaries are available for the Øresund model, see Figure 4.1.  

 

Hornbæk
Viken

Rødvig

Skanor

 
 
Figure 4.1 Map showing the water level stations at the boundaries: Hornbæk, Viken, Skanör, 

and Rødvig  

 

 

1 Measurements for 1993 were used for the MIKE 21 Flow Model example in Chapter 3 
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The Øresund model is forced with water level boundaries. The water level measurements 

indicate that the variations along the boundaries are significant, so the water level 

boundaries should be specified as line series (dfs1 type data file) containing an 

interpolation between the two measurements at each boundary. 

 

In the following, two line series (dfs1 type data file) with water level variations will be 

created on basis of measured recordings from the four stations on the two boundaries. 

The locations of the four stations are listed in Table 2.1. 

4.1.2 Importing measured water levels to time series file 

Open the Time Series Editor in MIKE Zero (File→New→ File→Time Series), see Figure 

4.2. Select the ASCII template. Open the text file waterlevel_rodvig.txt shown in Figure 

4.3. Change the time description to 'Equidistant Calendar Axis' and press OK, see Figure 

4.4. Then right click on the generated data in the Time Series Editor and select properties, 

see Figure 4.5. Change the item type to 'Water Level', see Figure 4.6, and finally, save 

the data in waterlevel_rodvig.dfs0.  

 

Repeat these steps for the remaining three stations. 

 

Please note that time series must have equidistant time steps in MIKE 21 & MIKE 3 Flow 

Model FM. That means that if the raw data have time gaps without measurements, the 

gaps in the raw data must be filled before importing it. 

 

  
 
Figure 4.2 Starting the Time Series Editor in MIKE Zero 
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Figure 4.3 ASCII file with water level recordings from Station Rødvig 

 

 

 
 
Figure 4.4 Time Series Editor: Import from ascii 
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Figure 4.5 Time Series Editor with imported water levels from Station: Rødvig 

 

 

 
 
Figure 4.6 Time Series Properties 

 

 

To make a plot of the water level time series open the Plot Composer in MIKE Zero, see 

Figure 4.7. Select 'plot' → 'insert a new plot object' and select 'Time Series Plot' (see 

Figure 4.8). 
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Figure 4.7 Starting the Plot Composer in MIKE Zero 

 

 

 
 
Figure 4.8 Plot Composer inserted a new Plot Object as Time Series 
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Figure 4.9 Plot Composer properties select time series to plot 

 

 

Add the actual time series file to the Plot Composer by clicking   and selecting the file, 

see Figure 4.9. It is possible to add more than one time series to the same plot. You might 

also change some of the properties for the plot, such as colours, etc. (see Figure 4.10). 
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Figure 4.10 Plot Composer Time Series Plot Properties dialogue for selecting time series files and 

adjusting scales, curves, etc. 

 

 

Figure 4.11 and Figure 4.12 show the measured water levels at the two boundaries. 

 

 

 
 
Figure 4.11 Combined Time Series at the North Boundary, Stations 1 and 2: Hornbæk and Viken 
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Figure 4.12 Combined Time Series at the South Boundary, Stations 3 and 4: Skanör and Rødvig 

 

4.1.3 Creating boundary conditions 

The next step is to create line series from the generated time series.  

 

Load the Profile Series in MIKE Zero (File→New→ File→Profile Series) and select 

'Blank ...'. Use default values for the geographical information in the first dialogue. 

 

In the next dialogue, fill in the required information listed below and as shown in Figure 

4.13: 

 

North Boundary 

• Start date 1997-09-01 00:00:00 

• Time step: 1800s  

• No. of time steps: 5856 

• No. of grid points: 10  

• Grid Step: 1000m (actually not necessary, because MIKE 21 & MIKE 3 Flow Model 

FM interpolates the line series to the boundary nodes without respect to this 

distance) 

 

Load Station Viken (waterlevel_viken.dfs0) in the Time Series Editor and copy and paste 

the water levels to the profile Series Editor at column 0 and 1. Next load Station Hornbæk 

(waterlevel_hornbaek.dfs0) and copy and paste the levels into column 8 and 9 (see 

Figure 4.14). This way the water levels are kept constant close to the coast, where the 

current velocities are expected to be low due to bottom friction. Interpolate the columns 2-

7 using the values in columns 1 and 8 (Tools→Interpolation). 

 

Save the profile series as waterlevel_north.dfs1 (see Figure 4.15). 
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Figure 4.13 Profile Series Properties 

 

 

 
 
Figure 4.14 Copying Viken water levels into Profile Series Editor 
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Figure 4.15 Water level line series at the North Boundary 

 

 

Repeat the same step with the southern boundary with a similar approach.  

 

Load Station Rødvig (waterlevel_rodvig.dfs0) in the Time Series Editor and copy and 

paste the water levels to the profile Series Editor at column 0 and 1. Next load Station 

Skanör (waterlevel_skanor.dfs0) and copy and paste the levels into columns 16 to 19 

(Because of a larger area with shallow water near the Swedish coast at the southern 

boundary). This way the water levels are kept constant close to the coast, where the 

current velocities are expected to be low due to bottom friction. Add values in columns 2-

15 by interpolating the data (Tools→Interpolation). Save the resulting file as 

waterlevel_south.dfs1. 

 

South Boundary 

• Start date 1997-09-01 00:00:00 

• Time step: 1800s  

• No. of time steps: 5856 

• No. of grid points: 20 

• Grid Step: 1600 m (actually not necessary, because MIKE 21 & MIKE 3 Flow Model 

FM interpolates the line series to the boundary nodes without respect to this 

distance) 

 

4.2 Initial Conditions 

The initial surface level is calculated as a mean level between the northern and the 

southern boundary at the beginning of the simulation. Load the two boundary files and 

approximate a mean level at the start of the simulation. We will use 0 m.  
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4.3 Wind Forcing 

Wind recordings from Ven Island will form the wind forcing as time series constant in 

space. Load the time series editor and import the ASCII file 'wind_ven.txt' as equidistant 

calendar axis (See Figure 4.16). Save the file in 'wind_ven.dfs0'. Time series of the wind 

speed and direction is shown in Figure 4.17. 

 

 
 
Figure 4.16 ASCII file with Wind speed and direction from Ven Island in Øresund 

 

 

A more descriptive presentation of the wind can be given as a wind - speed diagram. Start 

the 'Plot composer' insert a new plot object select 'Wind/Current Rose Plot' and then 

select properties and select the newly created file 'wind_ven.dfs0' and change properties 

to your need. The result is shown in Figure 4.18. 

 

 
 
Figure 4.17 Wind Speed and Direction from Ven Island as it can be viewed in the Plot Composer 

 

 



 MIKE 21 & MIKE 3 Flow Model FM 

40 Hydrodynamic Module - © DHI A/S 

 
 
Figure 4.18 Wind Rose from Ven Island as it can be viewed in the Plot Composer 

 

4.4 Density Variation at the Boundary 

As the area of interest is dominated with outflow of fresh water from the Baltic Sea and 

high saline water intruding from the North Sea, measurement of salinity and temperature 

has taken place at the boundaries. You can use two methods to generate a grid series 

boundary files from the measurements. You can for instance use a spread sheet to create 

an ASCII file from the raw data to import in MIKE Zero. In that case you must follow the 

same syntacs as the ASCII file in Figure 4.19. The first 13 lines in the ASCII file constitute 

a header containing information about for instance: 

 

1. Title 

2. Dimension 
3. UTM zone 
4. Start date and time 
5. No. of time steps 
6. Time step in seconds 
7. No. of x points and z points 
8. x and z-spacing in meters 
9. Name, type and unit of item in file 
10. Delete value  

 

After the mandatory header, the profile measurements are grouped in an x-z matrix for 

each item and time step. 

 

Another option is to enter the data manually directly in a new Grid Series file in MIKE 

Zero, see Figure 4.20. The choice of method depends on the amount of data, their format, 

and the users own experience with data processing, but both methods can be quite time 
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consuming2. In this example the ASCII files to import in MIKE Zero, containing the vertical 

profile values of the measurements for every 900 metres along the boundary, are already 

made and given in the ASCII files named:  

 

• salinity_north_boundary.txt 

• salinity_south_boundary.txt 

• temperature_north_boundary.txt  

• temperature_south_boundary.txt  

 

An example is shown in Figure 4.19. You should import these ASCII files with the Grid 

Series editor and save the files with the same name but with extension dfs2. A plot of a 

grid series boundary file for salinity is shown in Figure 4.20.  

 

Note that if the boundary condition has a fluctuating and complicated spatial variation it is 

difficult to measure and therefore generate correct boundary conditions. In that case it is 

often a good strategy to extend the model area so that the boundaries are placed at 

positions where the boundaries are less complicated and therefore easier to measure. 

 

 
 
Figure 4.19 Measured transect of temperature at the North Boundary 

 

 

 

2  DHI's MATLAB DFS function (see  

http://www.mikepoweredbydhi.com/download/mike-by-dhi-tools may be another option 

http://www.mikepoweredbydhi.com/download/mike-by-dhi-tools
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Figure 4.20 Grid Series Boundary file of salinity at the North Boundary 
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5 Set-Up of MIKE 21 Flow Model FM 

5.1 Flow Model 

We are now ready to set up the MIKE 21 Flow Model FM3 model using the Øresund mesh 

with 1993 water depths, and boundary conditions and forcing as generated in Chapter 3. 

Initially we will use the default parameters and not take into account the effect of the 

density variation at the boundaries. The set-up in the first calibration simulation consists of 

the parameters shown in Table 5.1. 

 
Table 5.1 Specifications for the calibration simulation 

 

Parameter Value 

Specification File oresund.m21fm 

Mesh and Bathymetry oresund.mesh (1993)    2057 Nodes in file 

Simulation Period 1993-12-02 00:00 – 1993-12-13 00:00 (11 days) 

Time Step Interval 120 s 

No. of Time Steps 7920 

Solution Technique Low order, fast algorithm 

Minimum time step: 0.01 s 

Maximum time step: 120 s 

Critical CFL number: 0.8 

Enable Flood and Dry Drying depth 0.01 m 

Flooding depth 0.05 m  

Wetting depth 0.1 m 

Initial Surface Level -0.37 m 

Wind Varying in time, constant in domain: 

wind_kastrup.dfs0 

Wind Friction Varying with wind speed: 

0.001255 at 7 m/s 

0.002425 at 25 m/s 

North Boundary  Type 1 data: waterlevel_north.dfs1 

South Boundary  Type 1 data: waterlevel_south.dfs1 

Eddy Viscosity Smagorinsky formulation, Constant 0.28  

Resistance Manning number. Constant value 32 m1/3/s 

Result Files flow.dfsu     ndr_roese.dfs0 

CPU Simulation Time About 25 minutes with a 2.4 GHz PC, 512 MB DDR 

RAM 

 

3 The MIKE 21 Flow Model FM, Hydrodynamic Module, User Guide can be accessed via the MIKE Zero 

Documentation Index in the start menu 
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In the following screen dumps of the individual input pages are shown and a short 

description is provided. 

 

The dialogue for setting up the MIKE 21 Flow Model FM is initiated from MIKE Zero, see 

Figure 5.1 (File→New→ File→MIKE 21→Flow Model FM). 

 

  
 
Figure 5.1 Starting MIKE 21 Flow Model FM in MIKE Zero 

 

 

Specify the bathymetry and mesh file oresund.mesh in the Domain dialogue, see Figure 

5.2. A graphical view of the computational mesh will appear. The projection zone has 

already been specified in the mesh as UTM-33. In the domain file each boundary has 

been given a code. In this Øresund example the North Boundary has the code 2 and the 

South Boundary has the code 3. Rename the boundary 'Code 2' to 'North' and 'Code 3' to 

'South' in the 'Boundaries' window in the Domain dialogue, see Figure 5.3. 

 

Specify an overall time step of 120 s in the Time dialogue. The time step range must be 

specified to 7920 time steps in order to simulate a total period of 11 days. See Figure 5.4. 
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Figure 5.2 MIKE 21 Flow Model FM: Specify Domain 

 

 

 
 
Figure 5.3 MIKE 21 Flow Model FM: Rename boundary codes to descriptive names in the 

Domain dialogue 
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Figure 5.4 MIKE 21 Flow Model FM: Simulation period 

 

 

In the Module Selection dialogue it is possible to include the 'Transport Module', the 

environmental 'ECO Lab Module', the 'Mud Transport Module', the 'Particle Tracking 

Module' and the 'Sand Transport Module'. Furthermore, it is possible to select 'Inland 

Flooding', see Figure 5.5.  

 

 
 
Figure 5.5 MIKE 21 Flow Model FM: Module Selection 
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In this example, only the Hydrodynamic Module will be used. Please see the Step-by-Step 

guides for the other Modules if you want to extend your hydrodynamic model with any of 

these modules. 

 

In the Solution Technique dialogue set the minimum and maximum time step to 0.01 and 

120 s, respectively. The critical CFL number is set to 0.8 to ensure stability of the 

numerical scheme throughout the simulation. 

 

 
 
Figure 5.6 MIKE 21 Flow Model FM: Solution Technique 

 

 

In the Depth dialogue it is possible to include a spatially varying depth correction. In this 

example, the bathymetry is kept as constant. 

 

In the Flood and Dry t is possible to include flood and dry, see Figure 5.7. In our case 

select a Drying depth of 0.01 m and a Flooding depth of 0.05 m. The Wetting depth 

should be 0.1 m. 

 

In this example the flooding and drying in the model should be included, because some 

areas along the shores of Saltholm will dry out during the simulation. If you choose not to 

include flooding and drying, the model will blow up in situations with dry areas. Including 

flooding and drying can however influence stability of the model, so if the areas that dry 

out are not important for the model study, you might consider not including flooding and 

drying. In that case you should manipulate the mesh file and make greater depths in the 

shallow areas to prevent those areas from drying out, and then run the model without 

flooding and drying. 

 

As the density variation is not taken into account in this example the density should be 

specified as 'Barotropic' in the Density dialogue, see Figure 5.8. 
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Figure 5.7 MIKE 21 Flow Model FM: Flood and Dry 

 

 

 
 
Figure 5.8 MIKE 21 Flow Model FM: Density specification 
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The default setting for the Horizontal Eddy Viscosity is a Smagorinsky formulation with a 

coefficient of 0.28, see Figure 5.9.  

 

 
 
Figure 5.9 MIKE 21 Flow Model FM: Eddy Viscosity 

 

 

The default Bed Resistance with a value given as a Manning number of 32 m1/ 3/s will be 

used for the first calibration simulation. In later calibration simulations this value can be 

changed, see Figure 5.10. 

 

Even though there are often strong currents in Øresund, the effect of Coriolis forces is not 

so significant, because the strait is rather narrow.  

 

However, Coriolis is always included in real applications. Only for laboratory type of 

simulations Coriolis is sometimes not included, see Figure 5.11. 
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Figure 5.10 MIKE 21 Flow Model FM: Bed Resistance 

 

 

 
 
Figure 5.11 MIKE 21 Flow Model FM: Coriolis Forcing 
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To use the generated wind time series specify it as 'Variable in time, constant in domain' 

in the Wind Forcing dialogue, and locate the time series wind_kastrup.dfs0. It is a good 

practice to use a soft start interval. In our case 7200 s should be specified. The soft start 

interval is a period in the beginning of a simulation where the effect of the wind does not 

take full effect. In the beginning of the soft start interval the effect of the specified Wind 

Forcing is zero and then it increases gradually until it has full effect on the model at the 

end of the soft start interval period. Specify the Wind friction as 'Varying with Wind Speed' 

and use the default values for the Wind friction. See. Figure 5.13. 

 

Note that an easy way to see the wind data file is to simply click  in the Wind 

Forcing dialogue, see Figure 5.12. 

 

 
 
Figure 5.12 MIKE 21 Flow Model FM: Wind Forcing 
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Figure 5.13 MIKE 21 Flow Model FM: Wind Friction 

 

In this example 

 

• Ice Coverage is not included  

• Tidal Potential is not included 

• Precipitation-Evaporation is not included 

• Infiltration is not included 

• Wave Radiation is not included 

• Structures are not included 

• Decoupling is not included 

 

The discharge magnitude and velocity for each source and sink should be specified in the 

Sources dialogue. But, because the sources in Øresund are too small to have significant 

influence on the hydrodynamics in Øresund they are not included in this example. So 

since we do not have any sources, leave it blank. See Figure 5.14. 

 

After inspection of the boundary conditions at the simulation start time decide the initial 

surface level. In this case we will use a constant level of -0.37m, which is the average 

between our North and South Boundary at the start of the simulation, see Figure 5.15. 
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Figure 5.14 MIKE 21 Flow Model FM: Sources 

 

 

 
 
Figure 5.15 MIKE 21 Flow Model FM: Initial Conditions 
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In the Boundary Conditions dialogue, the boundary conditions should be specified for the 

boundary names, which were specified in the Domain dialogue. There is a North 

Boundary and a South Boundary and the line series that were generated in Chapter 3 

should be used. See Figure 5.16. 

 

 
 
Figure 5.16 MIKE 21 Flow Model FM. The Boundary Conditions for the North Boundary are 

specified as waterlevel_north.dfs1 

 

 

In this case the boundary type is 'Specified Level' (Water Level), because only Water 

Level measurements are available at the boundaries. 'Specified Level' means that the 

Water Levels are forced at the boundaries, and the discharge across the boundary is 

unknown and estimated during simulation. In case you choose the boundary type as 

'Specified discharge' the discharge is forced and the water levels at the boundary are 

unknown and estimated during simulation.  

 

The boundary format must be set as 'Variable in time and along boundary' in order to 

specify the boundary as a line series file (dfs1). 

 

Click  and select the appropriate data file in the Open File window that appears, 

see Figure 5.18. 

 

For the North Boundary select the waterlevel_north.dfs1, and for the South Boundary 

select waterlevel_south.dfs1. 

 

Please note: when specifying a line series at the boundary it is important to know how 

MIKE 21 FM defines the first and last node of the boundary. The rule is: follow the 

shoreline with the discretised domain on the left hand side, see Figure 5.17. When a 

boundary is reached, this is the first node of the boundary.  

 

In Section 3.1.2 the data for the north boundary was generated using data from Hornbæk 

in the first grid point and data from Viken in the last grid point of the boundary line. This is 
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opposite the way MIKE 21 FM defines the direction of the boundary, and thus, the 

interpolation type for the north boundary should be set to reverse. 

 

 
 
Figure 5.17 MIKE 21 Flow Model FM. The Boundaries are defined by codes in the mesh file. In 

this case Code 2 is North boundary, code 3 is South boundary and code 1 is land 
boundary 

 

 

Use a soft start interval of 7200 s and a reference value corresponding to the initial value 

of –0.37 m. The soft start interval is a period in the beginning of a simulation where the 

effect of the boundary water levels does not take full effect. In the beginning of the soft 

start interval the effect of the specified Boundary Condition is zero and then the effect 

increases gradually until the boundaries has full effect on the model at the end of the soft 

start interval period.  

 

The boundary data corrections due to Coriolis and wind are omitted because the spatial 

extension of the boundary is relatively small. 

 

Note that an easy way to see the boundary data file is to simply click  in the 

Boundary dialogue. 
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Figure 5.18 MIKE 21 Flow Model FM: Boundary Select File 

 

 

Specify one output as area series and specify the resulting output file name, see Figure 

5.19. Specify the file name flow.dfsu for our first simulation. Make sure the required disk 

space is available on the hard disk. Reduce the output size for the area series to a 

reasonably amount by selecting an output frequency of 3600 s which is a reasonably 

output frequency for a tidal simulation. As our time step is 120 s, the specified output 

frequency is 3600/120 = 30. As default, the full area is selected. 

 

Pick the parameters to include in the output file as in Figure 5.20. 

 

Also specify an output file as point series at the calibration station at Ndr. Roese, see the 

position in Table 5.2. You might consider saving other time series from neighbouring 

points, so that you can see how much the results vary in the area near the monitoring 

station.  
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Figure 5.19 MIKE 21 Flow Model FM: Results can be specified as point, line or area series 

 

 

 
 
Figure 5.20  MIKE 21 Flow Model FM: The output Parameters specification 
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Table 5.2 Measurements at Ndr. Roese 

 

 

Station 

 

Data Files 

Position 

Easting 

(m) 

Northing 

(m) 

Ndr. Roese waterlevel_ndr_roese.txt 

currents_ndr_roese.txt 

354950 6167973 

 

 

Now we are ready to run the MIKE 21 Flow Model FM. (Run→Start simulation…). 

 

The specification file for this example has already been made: 

 
.\Calibration_1\oresund.m21fm 

 

Please note that if you experience an abnormal simulation, you should look in the log file 

(shown in the simulation tabs in the GUI) to see what causes the problem. Alternatively, 

you can use (File→Recent log file list) to select and open the log file in a separate 

window. 

 

After the simulation use the Plot Composer (or Data Viewer) to inspect and present the 

results. In the following Figure 5.21 and Figure 5.22 two plots are shown; one with 

currents towards North and one with currents towards South. 

 

The simulation data can be manipulated and extracted directly from dfsu result files by 

use of the Data Manager or the Data Extraction FM tool:  

 

File→New→File→MIKE Zero→Data Manager 

File→New→File→MIKE Zero→Data Extraction FM 

 

The Post Processing Tools (statistics, etc.) that are developed for the dfs2 and dfs3 

formats can also be used for dfsu files. It requires a conversion of the dfsu file to a dfs2 or 

dfs3 file first. There is a tool available for that conversion: 

 

File→New→File→MIKE Zero →Grid Series→From Dfsu File 
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Figure 5.21 Current speed and water level during current towards North 

 

 
 
Figure 5.22 Current speed and water level during current towards South 
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5.2 Model Calibration 

In order to calibrate the model we need some measurements inside the model domain. 

Measurements of water level and current velocities are available, see Table 5.2.  

 

5.2.1 Measured water levels 

Measurements of water level are given at Station Ndr. Roese (waterlevel_ndr_roese.txt). 

Import this ASCII file using the Time Series Editor (how to import ASCII files to time 

series, see Section 3.1.1). The water levels at Ndr. Roese are shown in Figure 5.23. 

 

 
 
Figure 5.23 Ndr. Roese: Measured water level  

 

5.2.2 Measured current velocity 

Measurements of current velocities are given at station Ndr. Roese 

(currents_ndr_roese.txt). Import this file with the Time Series editor. Plots of current 

velocity and current speed and direction are shown in Figure 5.24, Figure 5.25 and Figure 

5.26. 

 

 
 
Figure 5.24 Ndr. Roese: Measured current velocity East and North component  
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Figure 5.25 Ndr. Roese: Measured current speed and direction 

 

 

 
 
Figure 5.26 Ndr. Roese current rose, as it can be viewed with the Plot Composer 
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5.2.3 Compare model result and measured values 

Use the Plot Composer to plot the simulated and measured water level and current. A 

Plot Composer file for this purpose is already made in this example. Open the file 

ndr_roese.plc in: 

 

.\Calibration_1\Plots 

 

to see a comparison of measurements and model output of water levels and currents at 

Ndr. Roese. Plots as shown in Figure 5.27 will appear (only if your simulation was 

successful). 

 

The comparisons between measured and calculated water level and currents indicate that 

calibration might improve the results.  

 

Try changing the Bed Resistance to a Manning number of 45 m1/ 3/s and the Eddy 

Viscosity to a Smagorinsky value of 0.24 m1/ 3/s and run the set-up again. Now the model 

output fit the measurements better, see Figure 5.28. 

 

Try to calibrate further by changing the Manning number and the Eddy Coefficient with 

your own values. For each calibration simulation compare the results with the 

measurements. You should only change a single parameter at a time and track the 

changes in a log. Also be careful not to give values outside a realistic range. 

 

Note the way the folders are organised in the example: You can simply copy the 

Calibration_2 folder and rename it to Calibration_3. This way the Plot Composer file will 

also work for the new calibration simulation, because the path to the files in the Plot 

Composer file are relative to the present folder. If you are making many simulations this 

trick can save a lot of time. 
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Figure 5.27 Comparison of measurements and model output of water levels and currents at Ndr. 

Rose with default parameters 
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Figure 5.28 Comparison of measurements and model output of water levels and currents at Ndr. 

Rose after calibration 
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6 Set-Up of MIKE 3 Flow Model FM 

6.1 Flow Model 

We are now ready to set up the MIKE 3 Flow Model FM4 model using the Øresund mesh 

with 1997 water depths, and the boundary conditions and forcings that were generated in 

Chapter 4.  

 

The example has been divided into three sub periods:  

 

1. A warm up period (3 days simulation used to warm up the model) 

2. Period 1 ( 6 days simulation) 

3. Period 2 (12 days simulation) 

 

It is possible to open a specification file for each period, so that the example will not be 

too time consuming. The 'hot' initial conditions from the previous period to period 1 and 

period 2 are already supplied in the example. This way period 2, for instance, can be run 

without running period 1 first. 

 

It is recommended that you start working with the warm up period first in this example. 

Afterwards start looking at period 1 and 2. 

 

For the purpose of training do not start by opening the included specification files, but 

make your own specification files. The included specification files can be used for 

comparison. 

 

The data material in this example allows the user to make a new simulation period 3 up 

until December 1997. 

 

Hint for advanced users: Note that the total of 21 days can be simulated without opening 

the included specification files. Simply click on the bat file:  

 

.\Calibration_1\run_warmup_period1_period2.bat 

 

The trick with bat files can be useful when making many simulations. Starting the bat file 

will however overwrite the included hot initial conditions for period 1 and 2. So only start 

the bat job if it is intended to run the whole 21-day period. Otherwise open each 

specification file in the MIKE 3 Flow Model FM dialogues. 

 

Table 6.1 gives a summary of the set-ups: 

 
  

 

4 The MIKE 3 Flow Model FM, Hydrodynamic Module, User Guide can be accessed via the MIKE Zero Documentation 

Index in the start menu 
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Table 6.1 Summary of set-ups 

 

Parameter Value 

Specification File oresund.m3fm 

Mesh and Bathymetry oresund.mesh (1997),   2090 Nodes in file,    10 vertical equidistant layers 

Simulation Period (Warm up) 

 (Period 1) 

 (Period 2) 

1997-09-06 00:00 – 1997-09-09 00:00  (3 days) 

1997-09-09 00:00 – 1997-09-15 00:00  (6 days) 

1997-09-15 00:00 – 1997-09-27 00:00  (12 days) 

Time Step Interval (Warm up) 

 (Period 1) 

 (Period 2) 

7.2 s 

7.2 s 

108 s (Period 2) 

No. of Time Steps (Warm up) 

 (Period 1) 

 (Period 2) 

36000 

72000 

9600 

Solution Technique (Warm up) 

 (Period 1) 

 (Period 2) 

Critical CFL number: 1.0 

Critical CFL number: 1.0 

Critical CFL number: 0.8 

Enable Flood and Dry Drying depth 0.01 m 

Flooding depth 0.05 m 

Wetting depth 0.1 m 

Initial Surface Level (Warm up) 

Initial Temperature (Warm up) 

Initial Salinity (Warm up) 

Initial Conditions (Period 1) 

Initial Conditions (Period 2) 

0.0 

15.0 deg. C 

From file: salinity_sept_6_1997.dfs3 

Hot started from warm up period simulation 

Hot started from period 1 simulation 

Wind Varying in time, constant in domain: wind_ven.dfs0 

Wind Friction Varying with Wind Speed: 0.0015 at 0 m/s,    0.0026 at 25 m/s 

North Boundary Water Level 

 Temperature 

 Salinity 

Type 1 data: waterlevel_north.dfs1 

Type 2 data: temperature_north.dfs2 

Type 2 data: salinity_north.dfs2 

South Boundary Water Level 

 Temperature 

 Salinity 

Type 1 data: waterlevel_south.dfs1 

Type 2 data: temperature_south.dfs2 

Type 2 data: salinity_south.dfs2 

Result Files 2D_ndr_roese_flow.dfs0 (Time series) 

3D_ndr_roese_flow.dfs0 (Time series) 

2D_flow.dfsu (2D result file) 

3D_flow.dfsu (3D result file) 

Hot files  

CPU Simulation Time (Warm up) 

 (Period 1) 

 (Period 2) 

About 3½ hours with a 2.4 GHz PC, 512 MB DDR RAM 

About 7 hours with a 2.4 GHz PC, 512 MB DDR RAM 

About 15 hours with a 2.4 GHz PC, 512 MB DDR RAM 
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In the following screen dumps of the individual input pages are shown and a short 

description is provided. 

 

The dialogue for setting up the MIKE 3 Flow Model FM is initiated from MIKE Zero, see 

Figure 6.1. (File→New→File→MIKE 3→Flow Model FM) 

 

  
 
Figure 6.1 Starting MIKE 3 Flow Model FM in MIKE Zero 

 

 

Specify the bathymetry and mesh file oresund.mesh in the Domain dialogue, see Figure 

6.2. The projection zone has already been specified in the mesh as UTM-33. You should 

specify sigma mesh type and 10 equidistant vertical layers in the 'Vertical mesh' window. 

See Figure 6.3 

 

The mesh file contains information about boundaries. In this case there are 2 boundaries, 

and it is possible to give the boundaries more describing names than numbers. In this 

Øresund example the North Boundary has the code 2 and the South Boundary has the 

code 3. Rename the boundary 'Code 2' to 'North' and 'Code 3' to 'South' in the dialogue 

Boundary Names, see Figure 6.4. 

 

Specify the time step in the Time dialogue to 7.2 s. The time step range must be specified 

to 36000 time steps in order to simulate a total period of 3 days. See Figure 6.5. 
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Figure 6.2 MIKE 3 Flow Model FM: Specify Domain 

 

 

 
 
Figure 6.3 MIKE 3 Flow Model FM: Specify number of layers 
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Figure 6.4 MIKE 3 Flow Model FM: Specify Boundary Names: For instance North and South 

Boundary 

 

 

 
 
Figure 6.5 MIKE 3 Flow Model FM: Simulation period 

 

 

In the Module Selection dialogue it is possible to include the 'Transport Module', the 

environmental 'ECO Lab Module', the 'Mud Transport Module', The 'Particle Tracking' 

Module or the 'Sand Transport' Module, see Figure 6.6.  
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In this example, only the Hydrodynamic Module will be used. Please also see the relevant 

step-by-step training guides if you want to extend your hydrodynamic model with an 

ecological model, or a mud model. 

 

 
 
Figure 6.6 MIKE 3 Flow Model FM: Module Selection 

 

 

In the Basic Equations dialogue the Shallow Water Equations should be selected, since 

the non-hydrostatic pressure, which is the assumption in the Navier-Stokes Equations, 

has no significant impact on the modelling results for this example. 

 

In the Solution Technique dialogue the maximum time step is set to the overall time step. 

For the Warm up period and Period 1, the overall time step is small, itself ensuring a 

stable solution. Thus, the critical CFL number is set to 1.0. For Period 2, the overall time 

step is large. In this case the critical CFL number is set to 0.8 to ensure stability. Specify 

(‘Lower order, fast algorithm’) as the solution method and set the minimum time step 

(0.01s). 

 

In the Depth dialogue it is possible to include a spatially varying depth correction. In this 

example the bathymetry is kept as constant. 

 

In this example the Flooding and Drying in the model should be included, because some 

areas along the shores of Saltholm will dry out during the simulation. If you choose not to 

include Flooding and Drying, the model will blow up in situations with dry areas. Including 

Flooding and Drying can however influence stability of the model, so if the areas that dry 

out are not important for the model study, you might consider not including Flooding and 

Drying. In that case you should manipulate the mesh file and make greater depths in the 

shallow areas to prevent those areas from drying out, and then run the model without 

Flooding and Drying. In our case Flooding and Drying is included, so select a Drying 

depth of 0.01 m, a Flooding depth of 0.05 m, and a Wetting depth of 0.1 m, see Figure 

6.7. 
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Figure 6.7 MIKE 3 Flow Model FM: Flood and Dry specification 

 

 

Øresund is situated in a transition zone between the brackish Baltic Sea to the South and 

the more saline Kattegat to the North. Therefore, Øresund is often stratified with dense, 

saline water from Kattegat in the lower part of the water column and the brackish water 

from the Baltic Sea in the upper part of the water column. A sill across Øresund called 

Drogden allows the saline plumes from north to only pass the sill under certain long 

periods of uniform wind conditions. These wind conditions are rather rare and therefore 

large-scale intrusion of the saline Kattegat water across Drogden into the Baltic only 

happens every 7 years in average. 

 

In this example we will try to describe the salinities and temperatures in Øresund. 

Therefore the density should be specified as 'Function of temperature and salinity', see 

Figure 6.8. 

 

Specify the Horizontal Eddy Viscosity as Smagorinsky formulation with a constant value 

of 0.1, see Figure 6.9.  
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Figure 6.8 MIKE 3 Flow Model FM. Density specification. Density should in this example be a 

function of salinity and temperature 

 

 

 
 
Figure 6.9 MIKE 3 Flow Model FM. Horizontal Eddy Viscosity specification 
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Choose a two-equation turbulence model for the Vertical Eddy Viscosity. This formulation 

implies that the Turbulent Kinetic Energy must be determined with the Turbulence 

Module, see Figure 6.10. 

 

 
 
Figure 6.10 MIKE 3 Flow Model FM. Vertical Eddy Viscosity specification 

 

 

Next the Bed Resistance should be specified. In general the reasons for experiencing 

blow-ups are numerous. 

 

Two strategies can often be used to prevent instabilities: 

 

1. Increasing the Eddy Viscosity will 'smoothen' the values and can sometimes solve 

instability problems 

2. Increasing Bed Resistance can 'smoothen' Water Levels, and it can also dampen 

instabilities in some situations. 

 

It is best to solve the problem locally around the area causing problems, so that the trick 

of solving an instability problem does not significantly influence the calibration of results in 

other areas. 

 

A roughness height specified as a constant of 0.1 m is used, see Figure 6.11. 
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Figure 6.11 MIKE 3 Flow Model FM. Bed Resistance specification 

 

 

Even though there are often strong currents in Øresund, the effect of Coriolis forces is not 

so significant, because the strait is rather narrow. However, Coriolis is always included in 

real case applications. Only for laboratory type of simulations Coriolis is sometimes not 

included. So there is no reason for excluding Coriolis Forcing, because the effect on 

simulation time is small, see Figure 6.12. 

 

To use the generated wind time series you should specify it as 'Variable in time, constant 

in domain' in the Wind Forcing dialogue, and locate the time series wind_ven.dfs0.  

Note that an easy way to see the Wind data file is to simply click  in the Wind 

Forcing dialogue, see Figure 6.13. 

 

It is often a good practice to use a soft start interval. In our case 7200 s should be 

specified. The soft start interval is a period in the beginning of a simulation where the 

effect of the wind does not take full effect. In the beginning of the soft start interval the 

effect of the specified Wind Forcing is zero and then it increases gradually until it has full 

effect on the model at the end of the soft start interval period.  
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Figure 6.12 MIKE 3 Flow Model FM. Coriolis specification 

 

 

 
 
Figure 6.13 MIKE 3 Flow Model FM. Wind Forcing specification 
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Specify the Wind friction as 'Varying with Wind Speed' and use the values for the Wind 

friction as in Figure 6.14. 

 

 
 
Figure 6.14 MIKE 3 Flow Model FM. Wind Friction specification 

 

 

In this example 

 

• Ice Coverage is not included  

• Tidal Potential is not included 

• Precipitation- Evaporation is not included 

• Infiltration is not included 

• Wave Radiation is not included 

• Structures are not included 

 

The discharge magnitude and velocity for each Source and Sink should be specified in 

the Sources dialogue. But, because the sources in Øresund are too small to have 

significant influence on the overall hydrodynamics in Øresund they are not included in this 

example. So since we do not have any sources, leave it blank. See Figure 6.15. 

 

After inspection of the boundary conditions at the simulation start time you should decide 

the initial surface level. In this case we will use a constant Surface Elevation of 0.0 m for 

the warm up period, which is about the average value between our North and South 

Boundary at the start of the simulation, see Figure 6.16. 

 

The Period 1 and Period 2 simulations use the 'hot', simulated results from the previous 

period as initial conditions. 
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Figure 6.15 MIKE 3 Flow Model FM: Source and Sink 

 

 

 
 
Figure 6.16 MIKE 3 Flow Model FM: Hydrodynamic Initial Conditions 
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In the Boundary Conditions dialogue the boundary conditions should be specified for the 

boundary names that was specified in the Domain dialogue, see Figure 6.4. There is a 

North Boundary and a South Boundary and the line series that was generated in chapter 

3 shall be used.  

 

In this case the boundary type is 'Specified Level' (Water Level), because only Water 

Level measurements are available at the boundaries. 'Specified Level' means that the 

Water Levels are forced at the boundaries, and the discharge across the boundary is 

unknown and estimated during simulation. In case you choose the boundary type as 

'Specified discharge' the discharge is forced and the water levels at the boundary are 

unknown and estimated during simulation. A stable model in an area with two boundaries 

can often be obtained if one boundary is type 'Specified discharge' and another is type 

'Specified Level'. 

The Boundary Format must be set as 'Variable in time and along boundary' in order to 

specify the boundary as a line series file (dfs1). 

 

Click  and select the appropriate data file in the Open File window that appears. 

 

For the North Boundary select the waterlevel_north.dfs1, and for the South Boundary 

select waterlevel_south.dfs1.  

Note that an easy way to see the Boundary data file is to simply click  in the 

boundary dialogue. 

 

 
 
Figure 6.17 MIKE 3 Flow Model FM. The Boundaries are defined by codes in the mesh file. In this 

case code 3 is South boundary, code 2 is North boundary and code 1 is land 
boundary 
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Please note: When specifying a Line Series, or an Area Series at the boundary it is 

important to know how MIKE 21 FM defines the first and last nodes of the boundary. The 

rule is: follow the shoreline with the domain on the left hand side, see Figure 6.17. When 

a boundary is reached, this is the first node of the particular boundary.  

 

Use a soft start interval of 7200 s and a reference value corresponding the initial value of 

0.0 m. The soft start interval is a period in the beginning of a simulation where the effect 

of the boundary water levels does not take full effect. In the beginning of the soft start 

interval the effect of the specified Boundary Condition is zero and then the effect 

increases gradually until the boundaries has full effect on the model at the end of the soft 

start interval period. See. Figure 6.18. 

 

 
 
Figure 6.18 MIKE 3 Flow Model FM. The Boundary conditions for the North Boundary are 

specified as 'Variable in time and along boundary': waterlevel_north.dfs1 

 

 

The density in this example is a function of salinity and temperature. So the model 

specifications are enhanced with specifications for modelling salinity and temperature. In 

case you have any problems with stability of salinity or temperature, you have the option 

of range checking salinity and temperature in the Equation dialogue. Values outside the 

specified range are cut off, see Figure 6.19. So you should only use range checking if you 

cannot manage instabilities of salinity or temperature with other methods, because you 

may violate the mass budget with this method. 

 



 MIKE 21 & MIKE 3 Flow Model FM 

80 Hydrodynamic Module - © DHI A/S 

 
 
Figure 6.19 MIKE 3 Flow Model FM: Temperature/Salinity module range checking. Values outside 

the specified range of minimum and maximum values are cut off 

 

 

Use the same solution technique as in the Hydrodynamic module. 

 

The dispersion settings for the Temperature and Salinity module is for both the horizontal 

and vertical dispersion specified as Scaled Eddy Viscosity, see Figure 6.20. The 

horizontal sigma value should be set as 1. The vertical dispersion sigma value should be 

set as 0.1 to support a stratification of Øresund. Note that the dispersion settings are 

common for salinity and temperature. 

 

The heat exchange with the surroundings is included to simulate the temperatures better 

in the model. The default values are used and the air temperature is specified as 'Varying 

in time and constant in domain'. Use the file: temperature.dfs0. See Figure 6.21. 
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Figure 6.20 MIKE 3 Flow Model FM: Vertical Dispersion in the Temperature/Salinity module 

 

 

 
 
Figure 6.21 MIKE 3 Flow Model FM: Heat Exchange in the Temperature/Salinity module 
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When starting the simulation from scratch it takes approximately one to two weeks to 

warm up the salinity and temperature distributions in the Øresund model. Therefore, the 

results of salinity and temperature for the warm up period and the first part of Period 1 

cannot be expected to be right. In simulation period 2 (after 9 days' simulation), the 

salinity and temperature distributions should be quite 'hot'. This example has already 

been warmed up for the warm up period and Period 1 and the initial conditions are 

supplied with this example, so you can start the example for Period 2 with initial 

conditions as if the model had been running for a period of 9 days.  

 

In the warm up period, the initial conditions are specified as constant of 15C for 

Temperature, and a type 3 data file: salinity_sept_6_1997.dfs3 is used for the salinity, see 

Figure 6.22.  

 

 
 
Figure 6.22 MIKE 3 Flow Model FM: Initial Conditions in the Temperature/Salinity module in the 

Warm up simulation 

 

 

The file salinity_sept_6_1997.dfs3 is a very rough description of the horizontal distribution 

of salinity in Øresund in the beginning of September 1997. The dfs3 file was generated 

from a result file and measured values were interpolated into it. It is based on 

measurements and it does not contain information about the stratification and the vertical 

variation. 
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In the Boundary Conditions dialogue, the boundaries for temperature and salinity should 

be specified for the boundary names, which were specified in the Domain dialogue, see 

Figure 6.4. Enable the use of the grid series files that were generated in Chapter 4 by 

selecting the boundary data format ‘Varying in time and along boundary’. 

 

For the south boundary, select the files ‘temperature_south.dfs2’ and ‘salinity_south’ for 

the temperature and salinity at the boundary, respectively. 

 

For the north boundary select the files ‘temperature_north.dfs2’ and ‘salinity_north’ for the 

temperature and salinity at the boundary, respectively. 

 

Please note that for the north boundary, the contents of the dfs2 file are expressed in a 

west-east direction, i.e. opposite to the default direction of the north boundary. Hence the 

interpolation type in space must be defined as being in Reverse order.  

 

Use a soft start with a sinus variation and a time interval of 7200 seconds. For the 

temperature, use a reference value of 15º Celsius, and for the salinity, use a reference 

value of 22 PSU. 

 

 
 
Figure 6.23 MIKE 3 Flow Model FM: Boundary conditions for temperature at the south boundary 

in the Temperature/Salinity module 
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Figure 6.24 MIKE 3 Flow Model FM: Boundary conditions for salinity at the north boundary in the 

Temperature/Salinity module 

 

 

On the Equation dialog for the Turbulence Module, the k-epsilon formulation is chosen for 

Model type. The parameters for the model are kept as default values, see Figure 6.25 and 

Figure 6.26.  

 

Use the same Solution Technique as in the Hydrodynamic module. 

 

The boundary conditions for turbulence are set as constants, using the default values. 
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Figure 6.25 MIKE 3 Flow Model FM: Turbulence Equation specifications 

 

 

 
 
Figure 6.26 MIKE 3 Flow Model FM: Turbulence Dispersion specifications 

 

 

Decoupling is not included in the model. 
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The Model Output is divided into two groups: 

 

• 3D variables 

• 2D variables 

 

2D variables can be specified as Point Series, Line Series or Area Series. 

3D variables can be specified as Point Series, Line Series or Volume Series. See 

example of 3D output in Figure 6.27. 

 

 
 
Figure 6.27 MIKE 3 Flow Model FM: Results can be specified as point, line or area series 

 

 

Specify 6 output files: 

 

1. Volume Series and specify the resulting output file name. Specify the file name: 

3D_flow.dfsu.  

2. Area Series and specify the resulting output file name. Specify the file name: 

2D_flow.dfsu.  

3. Time Series at Ndr. Roese: 3D_ndr_roese.dfs0 

4. Time Series at Ndr. Roese: 2D_ndr_roese.dfs0 

5. A Hot Volume Series (only the last time step) and save in the Initial_Conditions 

folder. 

6. A Hot Area Series (only the last time step) and save in the Initial_Conditions folder. 

 

Make sure the required disk space is available on the hard disk. Reduce the output size 

for the Area Series and the Volume Series to a reasonably amount by selecting an output 

frequency of 3 hours. As the time step is 7.2 s then the specified output frequency is 

10800/7.2 = 1500. Default, the full area is selected for both Area Series and Volume 

Series. 
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The output files include a Point series at the calibration station at Ndr. Roese, see the 

position in Table 6.2. You might consider saving other time series from neighbouring 

points, so that you can see how much the results vary in the area near the monitoring 

station.  

 

 
Table 6.2 Measurements at Ndr. Roese 

 

 

Station 

 

Data Files 

Position 

Easting 

(m) 

Northing 

(m) 

Ndr. Roese salinity_ndr_roese_2.9.txt 

salinity_ndr_roese_5.9.txt 

salinity_ndr_roese_10.6.txt 

temperature_ndr_roese_2.9.txt 

temperature_ndr_roese_5.9.txt 

temperature_ndr_roese_10.6.txt 

u_velocity_ndr_roese_3.0.txt 

u_velocity_ndr_roese_6.0.txt 

u_velocity_ndr_roese_10.5.txt 

v_velocity_ndr_roese_3.0.txt 

v_velocity_ndr_roese_6.0.txt 

v_velocity_ndr_roese_10.5.txt 

waterlevel_ndr_roese.txt 

354950 

354950 

354950 

354950 

354950 

354950 

354950 

354950 

354950 

354950 

354950 

354950 

354950 

354950 

6167973 

6167973 

6167973 

6167973 

6167973 

6167973 

6167973 

6167973 

6167973 

6167973 

6167973 

6167973 

6167973 

6167973 

 

 

Pick the 3D parameters to include in the output files as shown in Figure 6.28 and the 2D 

parameters as shown in Figure 6.29. 
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Figure 6.28 MIKE 3 Flow Model FM: The 3D Output Parameters specification 

 

 

 
 
Figure 6.29 MIKE 3 Flow Model FM: The 2D Output Parameters specification 

 

 

Now we are ready to run the MIKE 3 Flow Model FM. 

 

The specification files for this example have already been made: 

 
.\Calibration_1\Varmup\oresund.m3fm 
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.\Calibration_1\Period_1\oresund.m3fm 

 

.\Calibration_1\Period_2\oresund.m3fm 

 

After the simulation, you should use the Plot Composer (or Grid Editor or Data Viewer) to 

inspect and present the results. Two plots are shown below; one top view with salinities 

and vectors for current speed and direction (Figure 6.30) Another plot is a side view 

showing a profile along a line through the middle of Øresund from North to South (Figure 

6.31). 

 

The Post Processing Tools (data extraction, statistics, etc.) that are developed for the 

dfs2 and dfs3 formats can also be used for dfsu files. It requires a conversion of the dfsu 

file to a dfs2 or dfs3 file first. There is a tool available for that conversion: 

 

File→New→File→MIKE Zero→Grid Series→From Dfsu File 

 

 
 
Figure 6.30 Top view with salinities and vectors for current speed and direction  

 

 

 
 
Figure 6.31 Side view showing the salinity profile along a line through the middle of Øresund from 

North (left) to South (right) 
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6.2 Model Calibration 

In order to calibrate the model we need some measurements inside the model domain. 

Measurements of water level, current velocities, salinities, temperatures at Ndr Roese are 

available for different depths, see Table 6.2. 

 

6.2.1 Measurements of water levels, salinities, temperature and currents 

Measurements of water levels are given at Ndr. Roese. Import this ASCII file using the 

Time Series editor. See Figure 6.32. 

 

 
 
Figure 6.32 Ndr. Roese Measured Water Level  

 

The salinities, temperatures and current velocities are given at 3 depths at station Ndr. 

Roese, see Table 6.2. Import these files with the Time Series editor.  

 

 

6.2.2 Compare model result and measured values 

Compare the simulated values at Ndr. Roese with measured values. Use the Plot 

Composer to plot the simulated and measured values of water level, currents, salinity, 

and temperature for both the Period 1 and Period 2. 

 

The comparison is shown in Figure 6.33 and Figure 6.34for water levels at Ndr. Roese in 

Period 1 and Period 2. The water levels look reasonable. 
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Figure 6.33 Water level comparison at Ndr. Roese. Period 1 

 

 

 
 
Figure 6.34 Water level comparison at Ndr. Roese. Period 2 

 

 

The Current comparison for Ndr. Roese is shown in Figure 6.35 and Figure 6.36. For 

Period 2, the model seems to be 'hot' and the results look good. 
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Figure 6.35 Current Velocity North comparison at Ndr. Roese. Period 1 
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Figure 6.36 Current Velocity North comparison at Ndr. Roese. Period 2 
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For the temperature results comparison at Ndr. Roese, see Figure 6.37 and Figure 6.38, 

the model results look good for Period 2, in particular. 

 

 

 
 
Figure 6.37 Temperature comparison at Ndr. Roese. Period 1 
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Figure 6.38 Temperature comparison at Ndr. Roese. Period 2 
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For the salinity results comparison at Ndr. Roese, see Figure 6.39 and Figure 6.40, the 

model results look reasonable for Period 1. However, for Period 2, where the paradigm 

changes from a well-mixed water column with salinities around 21 PSU to a well-mixed 

water column with salinities around 11 PSU, the transition from one system to the other is 

not described with great accuracy. The end levels are correct though.  

 

 

 
 
Figure 6.39 Salinity comparison at Ndr. Roese. Period 1 
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Figure 6.40 Salinity comparison at Ndr. Roese. Period 2 

 

 

You could try calibrating the Dispersion properties of salinity to get a better agreement of 

the salinity in Period 2. 

 

For each calibration simulation compare the results with the measurements. You should 

only change a single parameter at a time and track the changes in a log. Also be careful 

not to give values outside a realistic range. 

 

Note the way that the folders are organised in the example: You can simply copy the 

Calibration_2 folder and rename it to Calibration_3. This way the Plot Composer file will 

also work for the new calibration simulation, because the paths to the files in the Plot 

Composer file are relative to the present folder. If you are making many simulations this 

trick can save a lot of time. 
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