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Notes: 

• The exercises assume that you have already installed MIKE SHE, and it is correctly 
licensed (Demo or a Full License).  

• These step-by-step exercises are designed to illustrate the basic functionality 
available in the user interface and the basic steps required for integrated 
groundwater-surface water modelling.  

• Although these exercises are based on real case studies, they have been 
significantly simplified to make the models run quickly. Thus, the parameter values 
may not be representative of real world values.  Therefore, the exercises are not 
intended to illustrate best practices in integrated modelling. 

• Although the entire exercises will not run in the demo mode, the exercises can be 
easily modified so that they will run in the demo mode by reducing the number of 
nodes or the simulation length. The necessary changes are noted in the exercises. 

• As you do the exercises, you should initially take some time to look at the figures on 
each page before reading the text. This should help you understand the exercise 
instructions. 
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1 Introduction 

In the hydrological cycle, water evaporates from the oceans, lakes and rivers, from the 
soil and is transpired by plants. This water vapour is transported in the atmosphere and 
falls back to the earth as rain and snow. It infiltrates to the groundwater and discharges to 
streams and rivers as base flow. It also runs off directly to streams and rivers that flow 
back to the ocean. The hydrologic cycle is a closed loop and our interventions do not 
remove water; rather they affect the movement and transfer of water within the hydrologic 
cycle.  
 
MIKE SHE is an advanced, flexible framework for hydrologic modelling. It includes a full 
suite of pre- and post-processing tools, plus a flexible mix of advanced and simple 
solution techniques for each of the hydrologic processes. MIKE SHE covers the major 
processes in the hydrologic cycle and includes process models for evapotranspiration, 
overland flow, unsaturated flow, groundwater flow, and channel flow and their 
interactions. Each of these processes can be represented at different levels of spatial 
distribution and complexity, according to the goals of the modelling study, the availability 
of field data and the modeller’s choices. The MIKE SHE user interface allows the user to 
intuitively build the model description based on the user's conceptual model of the 
watershed. The model data is specified in a variety of formats independent of the model 
domain and grid, including native GIS formats. At run time, the spatial data is mapped 
onto the numerical grid, which makes it easy to change the spatial discretisation. 
 
MIKE SHE uses MIKE HYDRO river to simulate channel flow. MIKE HYDRO includes 
comprehensive facilities for modelling complex channel networks, lakes and reservoirs, 
and river structures, such as gates, sluices, and weirs. In many highly managed river 
systems, accurate representation of the river structures and their operation rules is 
essential. In a similar manner, MIKE SHE is also linked to the MOUSE sewer model, 
which can be used to simulate the interaction between urban storm water and sanitary 
sewer net-works and groundwater. MIKE SHE is applicable at spatial scales ranging from 
a single soil profile, for evaluating crop water requirements, to large regions including 
several river catchments, such as the 80,000 km2 Senegal Basin. MIKE SHE has proven 
valuable in hundreds of research and consultancy projects covering a wide range of 
climatological and hydrological regimes.  
 
The need for fully integrated surface and groundwater models, like MIKE SHE, has been 
highlighted by several independent studies. These studies show that few codes exist that 
have been designed and developed to fully integrate surface water and groundwater. 
Further, few of these have been applied outside of the academic community.  
 
MIKE SHE has been used in a broad range of applications. It is being used operationally 
in many countries around the world by organisations ranging from universities and 
research centres to consulting engineers companies. MIKE SHE has been used for the 
analysis, planning and management of a wide range of water resources and 
environmental and ecological problems related to surface water and groundwater, such 
as: 
 
• River basin management and planning  
• Water supply design, management and optimisation 
• Irrigation and drainage 
• Soil and water management 
• Surface water impact from groundwater withdrawal  
• Conjunctive use of groundwater and surface water  
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• Wetland management and restoration  
• Ecological evaluations 
• Groundwater management  
• Environmental impact assessments  
• Aquifer vulnerability mapping 
• Contamination from waste disposal  
• Surface water and groundwater quality remediation  
• Floodplain studies  
• Impact of land use and climate change  
• Impact of agriculture (irrigation, drainage, nutrients and pesticides, etc.)  

1.1 The MIKE SHE user interface 

 
 
MIKE SHE’s user interface can be characterised by the need to 
 
• Develop a GUI that promotes a logical and intuitive workflow, which is why it includes 

- A dynamic navigation tree that depends on simple and logical choices 
- A conceptual model approach that is translated at run-time into the mathematical 

model 
-  Object oriented “thinking” (geo-objects with attached properties) 
-  Full, context-sensitive, on-line help 
-  Customised input/output units to support local needs  

• Strengthen the calibration and result analysis processes, which is why it includes 
-  Default HTML outputs (calibration hydrographs, goodness of fit, water balances, 

etc.) 
-  User-defined HTML outputs 
-  A Result Viewer that integrates 1D, 2D and 3D data for viewing and animation 
-  Water balance, auto-calibration and parameter estimation tools. 
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• Develop a flexible, unstructured GUI suitable for different modelling approaches, 
which is why it includes 
-  Flexible data format (gridded data, .shp files, etc.) that is easy to update for new 

data formats 
-  Flexible time series module for manipulating time-varying data  
-  Flexible engine structure that can be easily updated with new numerical engines 

The result is a GUI that is flexible enough for the most complex applications imaginable, 
yet remains easy-to-use for simple applications. 
 
In addition to the MIKE ZERO Project Explorer, the MIKE SHE document consists of 4 
parts: 
 
• Along the top - the Tool bar and drop-down Menus  
• On the left - the dynamic Data tree and tab control 
• In the middle - the context sensitive Dialog area 
• On the right - the Project Explorer 
• Along the bottom - the Validation area and Mouse-over data area 

Tool bar - contains icon short cuts for many MIKE SHE operations that can be accessed 
via the Menus. The Tool bar changes depending on the tools that are currently in use.  
 
Data tree - displays the data items required to run the model as it is currently defined. If 
you add or subtract hydrologic processes or change numeric engines, the make-up of the 
data tree will change. 
 
Dialog area - is different for each item in the data tree.  
 
Validation area - displays information on missing data or invalid data items. Any items 
displayed here are hot linked to the Dialog in which the error has occurred.  
 
Mouse-over area - displays dynamic coordinate and value information related to the 
mouse position in the map area of any of the spatial Dialogs.  
 
Project Explorer - displays the list of files that are in the current project. This is only 
active if the model is opened and edited via a Project File. Otherwise the section is blank.  
 



 MIKE SHE 

4 Fully Integrated Exercises - © DHI 

  



Getting Started Exercise  

 5 

2 Getting Started Exercise 

Objective  

Learn how to create a MIKE Zero Project and the associated project documents. Save the 
MIKE SHE Examples Project locally for use in the exercises.  

2.1 Start MIKE SHE 

2.1.1 Launch MIKE Zero  

• from the Program menu select MIKE Zero: 

The Program Files menu looks different depending on your operating system and your 
settings.  
 

  
 
MIKE SHE is part of the MIKE Zero suite of modelling tools, which is a global DHI user 
interface for managing and manipulating data files and projects for many of the MIKE 
Powered by DHI software products. Thus, when you launch MIKE SHE, you are really 
launching MIKE Zero. MIKE Zero then provides the framework from which you can run 
MIKE SHE or any other product in the MIKE Zero family. 
 
Also notice in the Start Menu icons for  
 
MIKE SDK – this is set of programming functions and documentation that allows you to 
manipulate MIKE by DHI input and output files programmatically.  
 
DHI License Administration – this launches a tool for managing your software licenses  
 
MIKE View – This is a tool for evaluating the results of MIKE HYDRO River 
 
Documentation – This links to a directory of all the installed documentation files 
 
Release notes – Here you can find the latest information on the service packs that have 
been installed 
 
MIKE to Google Earth – This tool allows you to map your results onto Google Earth 
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2.2 The MIKE Zero project 

MIKE Zero is more than a set of modelling tools. MIKE Zero is a project management 
interface, with a full range of tools for helping you with your modelling project. 

2.2.1 The MIKE Zero project window 

The MIKE Zero Start Page includes two parts:  
 
1. The Project Overview table lists the projects that you have recently accessed, 

along with their creation and last modified dates.  
 
2. The Project Explorer is a view into the directory with all the files that are associated 

with the project.  

The MIKE Zero project structure is designed to help you keep control of your project. By 
default it appears on the right hand side of the MIKE ZERO interface. 
 

 
 

2.2.2 Install the MIKE Zero examples 

The versions in the Program Files directory are read-only and provide you with an 
uncorrupted version of the example files. The Install Examples button copies all of the 
example files from the installation directory into your chosen directory for use in these 
exercises. If you want to start over, then you can simply re-install the examples. 
 
• Click on the [Install Examples...] button and then select to install all of the MIKE 

SHE example files 

• Select your Destination Directory to be the Documents/MIKE Zero Projects 
directory 

Now you have a local duplicate copy of the Examples Project for use in these exercises.  
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For all of these exercises, please use the versions found in the Documents 
directory you just created. 
 

 

2.2.3 Open the default examples project 

After you have started MIKE Zero navigate to the default location of the installed MIKE 
SHE Examples Project. 
 

• Select the  button below the project list. 

• Browse to the folder: \Documents\MIKE Zero Projects\MIKE_SHE  

• Then open the existing project: MIKE SHE exercises.mzp 

 
 
The files contained within the MIKE SHE Examples project will now appear in the Project 
Explorer 
 
The Project Explorer may be hidden on the right side of the MIKE Zero window. If so, drag 
your mouse over to the Project Explorer tab, and the Project Explorer will appear. For this 
exercise, it is probably useful to lock the Project Explorer in place. This is done by clicking 
on the little thumbtack icon in the upper right hand corner of the Project Explorer. You are 
welcome to hide or unhide the Project Explorer at any time during the exercise.  
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If you have opened this project before, the project will be displayed in the list box. In this 
case, open by clicking on the project name.  
 
Note: The Project Explorer may open with all the directories expanded out. So, you might 

like to close up some of the directories in the Project Explorer by clicking on the little   
icons.  

2.2.4 MIKE Zero Features 

Some features of the MIKE Zero main dialog are worth knowing about.  

Toolbar 

New files can be created and existing files opened from the New, , and Open, , 

icons. There is a Save, , icon that is active when you have a file open. However, 
MIKE SHE automatically saves your model whenever you Pre-process the data or Run a 
simulation.  
 
Various other toolbars will be visible and active, depending on which files are open and 
the context of your cursor.  
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File menu 

 
 
Under the File menu, there are some useful functions related to the overall setup of MIKE 
Zero.  
 
Edit Unit Base Groups – this dialog allows you to change the default units associated 
with any parameter in MIKE SHE. The list of parameters is very long because it includes 
all parameters for all the MIKE Zero models by default.  
 
• Note on working with Imperial units – By default, MIKE SHE works in SI units. In 

this dialog, you can load a template for US units. This will change all of the displayed 
units in the MIKE SHE dialogs to Imperial US units. However, be aware that MIKE 
SHE still works internally in SI. Thus, the log files etc are still written in SI units.  

Edit Map Projections – this dialog allows you to add new map projections or edit existing 
map projects. The list is quite comprehensive, but your GIS organization may have 
special requirements.  
 
User Settings – this dialog contains some useful setting, in particular, it allows you to 
change the default directory for new models etc. For example, if you always work on a 
shared network drive, you may want to change the default.  
 
Project Properties – if you are using MIKE Zero Projects, then you may want to change, 
for example, the default location for your results.  

2.2.5 Getting help  

If you are using this exercise in a course, you are welcome to ask your instructor at any 
time for help.  
 
However, if you are working on your own, there is an extensive on-line help.  
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• On-line Help - The full Help can be accessed from the top Help… menu. For MIKE 

SHE, this is the same as the full printed manuals.  

 . 

 
• F1 Context Help - From within the Dialogs, context sensitive help is available by 

pressing the F1 key.  This takes you to a specific help page for the dialog that you 
are currently viewing in the user interface.  

 

 

 
• Reference Manuals - The full documentation in PDF format can be accessed from 

the Start Menu (Windows 7) or under the Apps in Windows 10.  
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   or    
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2.2.6 Technical Support 

Not all answers can be found in the documentation and help pages. In these cases, we 
are always available to answer questions via our Support Desk at mike@dhigroup.com.  
 
You are also welcome to join our on-line user community at 
http://forum.mikepoweredbydhi.com/. Here you can post questions and learn from other 
users.  
 

End of Getting Started Exercise. 
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3 Setting up a MIKE SHE Flow Model 

The purpose of this exercise is to set up an integrated MIKE SHE model using predefined 
inputs. Through the exercise, basic MIKE SHE operations are practised and you will 
become familiar with various model tools for result processing. 
 
The exercise is divided into two parts.  
 
This Section covers the following topics:   
• Creating a model 
• Setting up the model domain and grid 
• Adding the topography 
• Specifying climate and land use 
• Setting up the various modules: overland, unsaturated and saturated flow; and 
• Controlling the outputs. 
 
The second part, Section 4, covers  
• Running the model, and  
• Using some of the post-processing tools to evaluate the results 
 
The models in these exercises are based on the Karup River catchment in western 
Denmark. 

3.1 Create a new MIKE SHE setup 

In the following steps you will be creating and building a new MIKE SHE model of the 
catchment based largely on pre-existing data files.  
 
Ensure that you have installed the Example files in the previous Getting Started exercise, 
and have opened the MIKE SHE exercises.mzp project file in the My Documents folder.  

3.1.1 Create a new MIKE SHE document 

A MIKE Zero project is a collection of documents. All of the MIKE Powered by DHI 
documents can be created from the File\New\File... menu in the top pull-down menu or 

by clicking on the New File icon,  , in the toolbar.  
 
When the New File Dialog appears,  
• select MIKE SHE on the left hand side, 
• select Flow Model (.she) on the right hand side, 
• click OK. 
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The default MIKE SHE Setup Dialog will now appear and the new .she file will be added 
to the project under the Model directory. 
 
The .SHE file contains all the user-specified information required to run MIKE SHE. 
However, the file does not contain the actual time series and grid data. MIKE SHE only 
stores the path names to the other data files for time-series data and grid data. This 
greatly improves the flexibility of the user interface for keeping your model up-to-date with 
new data and for running calibration and prediction scenarios 
 
You can use the same New document dialog to select any of the listed file types on the 
right hand side, or even navigate to one of the other items on the left hand side. For 
example, you may need to create a water balance (.wbl) file during calibration, or a new 
dfs0 time series file, which you will find under the MIKE Zero list. 

3.1.2 Save the document file 

The document file that you just created – in this case the .she document – is unnamed 
until you save it.  
 
To save the file: 
 
• First. Click on the Karup_Basic directory in the Project Explorer (this becomes the 

default location for the file to be saved to and ensures that the .she file is located 
correctly within the project folder structure ) 

• Then, use the File\Save menu item, or the Save icon    
• In the Save Dialog type in a file name (e.g. MyFirstMSHE – the .she extension will be 

added automatically) 
• Click OK 
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3.2 Set up the map overlays 

In many projects, the first thing you may want to do is to define the maps and overlays 
that you are going to use in your project.  
 
MIKE SHE allows you to add graphical overlays using bitmaps, ArcView .shp files, etc. 
These overlays will appear on all maps shown in the graphical view in the user interface. 

3.2.1 Set the display area  

The basic display area of the model map view is defined in the top item of the data tree 
Dialog under Display: 
 
• Use your mouse pointer to select Display 

The Display item is located at the top of the data tree to make it easy to add and edit your 
background maps. In the Display item, you can add any number of images to your model 
setup, in a variety of formats. The images are carried over to the various editors, so you 
can keep a consistent display between the set up editor and, for example, the Grid Editor 
and the Results Viewer. 
 
The option ' Default map display based on the Model Domain' means that the map view 
will be defined by the size of the model domain that you select in the next section of this 
exercise.  
 
However, in some cases you may want the displayed map area should be much larger 
than the model domain, in which case you can define the map extents in this Dialog. 
 
You can also import the extents from a shape or dfs2 file.  
 
• In this case set the display area manually. The Karup model is set up in UTM_32N 

coordinates 

• Lower Left corner: (Xmin, Ymin)=(493900, 6220750) 

• Upper Right corner: (Xmax,Ymax)=(526400,6255750) 
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3.2.2 Add an image map overlay  

In the Foreground Dialog under Display: 
 

• Click on the Add Item icon   

 
Notice that a plus sign (+) appears beside the Foreground item in the data tree. This 
indicates that sub-items have been added in the data tree. 
 
The Background and Foreground options refer to the way the overlays are displayed 
relative to the input data specified in the other Dialogs. Typically, you only need the 
Foreground display active.  
 
Also, if you have multiple overlays, the order that they are listed defines the order in which 
they are displayed. Thus, you don't usually want a bitmap at the top of the list, since it 
would hide all of the lower overlays. 
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3.2.3 Define the file and geo-reference the bitmap 

Now click on the plus sign beside the Foreground item in the data tree to expand the data 
tree. Then click on the sub-item to display the sub-Dialog. 
 

 
 
In the sub-Dialog: 

• click on the browse button,  , and find the file  
.\Karup_Basic\Model Inputs\GIS Data\D200_2015.bmp  

Since a bitmap image does not contain any geographical information (it is simply a list of 
pixel locations and colours), the bitmap must be oriented in space. To do so, you can 
either import the georeferenced coordinates from a world file or provide MIKE SHE with 
the coordinates of the lower left and upper right corners of the bitmap.  
 
• Type in the coordinates as shown in the figure above 

• Click on Display to make the map visible 

• Set the Display style as Blend Colors, which will blend the map colours with any 
other displayed colours. This will prevent the bitmap from hiding the model data. 
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3.3 Set up the simulation 

MIKE SHE includes several simulation modules. The navigation tree in the user interface 
depends on your choice of simulation modules.  

3.3.1 Select simulation modules  

In the Simulation Specification Dialog, make sure that all the  the Water Movement items 
are checked On. Make sure that;  
 
• Rivers and Lakes are on;  

• Finite Difference is selected for the OL and SZ engines, and  

• the Richards equation is selected for the UZ engine. 

 
 
The Simulation Specification Dialog allows you to select, which flow components to 
include in your simulation. For example, if you want to include only the river and the 
exchange to the saturated zone, then you only need to select Rivers and Lakes plus 
Saturated Flow.  
Not selecting some of the items can be a useful option during the initial model setup stage 
when you are setting up and calibrating a complex model.  
 
In this dialog, you chose the numeric engine for the different hydrologic processes.  
 
• There are three numeric engine options for the unsaturated zone and two each for 

both the Overland flow and Saturated Flow.  

• The calculation method for the Evapotranspiration is automatically selected 
depending on the Unsaturated Flow option selected.  

• The channel flow numerical method is selected in the MIKE HYDRO Setup. 
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3.3.2 Specify the simulation period 

In the Simulation period Dialog:  
 
• Specify the Start date and End date 

-  Start Date: 1 January 2003 
-  End Date: 31 December 2007 

In this Dialog, you can either type in the dates or select the dates from a drop down 
calendar. 
 

 
 
Demo Note: If you are using a Demo version, then the maximum length of simulation is 
30 days. In this case you should use a shorter Simulation Period. For example, only the 
month of January 2003 
 
If your simulation runs too slowly, then you can reduce the length of the simulation 
period without affecting the learning objectives. 
 
Specification of the simulation period at this early stage in the model development is not a 
requirement. However, it is convenient because the time-varying input data you specify 
later is validated against the simulation period. Thus, when you specify a rainfall time-
series file, a check is made to make sure that the time-series covers the simulation 
period. 
 
In most cases, MIKE SHE is run as a transient model. If the model is run in steady-state, 
then the steady-state solution also follows this simulation period, by generating a series of 
identical steady-state solutions for each specified time step.  
 
Typically, you will start the simulation from a Hot start condition. But, in this exercise we 
will start it from the defined initial conditions. The Hot-start allows you to start the 
simulation from the end of a previous simulation. You will often create a ‘run-in’ simulation 
that allows the model to dynamically equilibrate. Then, start the actual simulation at, for 
example, the end of a dry season.  
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3.3.3 Define time step parameters 

In the Time step control dialog specify: 
 
• Initial time step = 2 hrs 

• Max allow OL time step = 0.25 hrs 

• Max allow UZ time step = 2 hrs 

• Max allow SZ time step = 2 hrs 

 
 
MIKE SHE uses different time-steps for the different hydrologic processes. Normally, the 
Overland flow time-step is the smallest and the Groundwater time-step the largest. The 
river time step is controlled in MIKE HYDRO.  
 
The overland flow time step is quite small because it is highly dynamic. The overland time 
step has to be the same or larger than the MIKE Hydro Time step 
 
Generally, the time steps are relatively small in this example because the system is quite 
sandy and highly dynamic. In a less dynamic simulation, you would normally make the SZ 
time step larger.  
 
The Max infiltration amount and the Max precipitation depth per time step are used to 
improve the numeric stability of the solution when there is ponded water on the ground 
surface. If the maximum values are exceeded, then the time step will be automatically 
decreased until this limit is reached. 

3.3.4 Simulation control 

We will use the default values for all the solver parameters. Details on these parameters 
can be found in the on-line Help. 

Overland flow  

You should use the default parameters for OL, but change to the Explicit solver. Leave 
the Manning equation for calculating overland flow into the rivers. 
 
If you want to calculate flooding, then the explicit solver is required. However, the time 
step constraints on the explicit solver are more restrictive.  



Setting up a MIKE SHE Flow Model  

 21 

 

Unsaturated flow 

We will use the default UZ solver parameters.  
 

 
 
Richard’s equation for unsaturated flow may produce water balance errors if the time step 
is large and the control parameters are set too loosely. Increasing the iteration control 
parameters will however increase the runtime which may not be desirable.  
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Problems with the water balance are reported in the water movement run log file and 
should be checked at the end of every simulation. It is also advisable to run the water 
balance tool to make sure the model is performing correctly. 
 

Saturated flow 

You should use the default parameters for SZ including the default PCG Transient solver 
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3.4 Set up the model domain 

The model domain and the surface topography are required for all MIKE SHE 
components. 
 
The model domain defines the horizontal extent of the model area, as well as the 
horizontal discretisation used in the model for overland flow, unsaturated flow and 
saturated groundwater flow 

3.4.1 Define the model domain 

In the Model Domain and Grid Dialog: 
 

 
 
• Choose Catchment defined by Shape File 

• Using the Browse icon, select the file 
.\Model Inputs\GIS Data\catchment.shp 

• Set the Shape axis units to “meter”. 

• Set the grid dimensions to  
-  Number of cells in the X direction, NX = 65 
-  Number of cells in the Y direction, NY = 70 
-  Cell size = 500m 
-  Rotation = 0 
-  Origin (X0, Y0) = 493900, 6220750 



 MIKE SHE 

24 Fully Integrated Exercises - © DHI 

• Map Projection Type = ETRS_1989_UTM_Zone_32N  
 

A list of previously used map projections will appear in the drop down menu when 
selecting Map Projection Type. To find and use the projection for the first time  

 
• click <Browse…>  

• go to: OpenGISProjections/Coordinate Systems/Projected Coordinate 
Systems/UTM/Other GCS/ ETRS_1989_UTM_Zone_32N 

• Click OK 

  
 
The Map Projection Type allows you to use any valid map projection. The only restriction 
is that whichever projection you chose, you must be consistent with respect to all other 
map inputs. You cannot mix, for example, maps from two different UTM zones.  
 
The NON-UTM option implies local rectangular coordinates, without a map projection. 
 
MIKE SHE automatically assigns values of 1 to the internal cells and values of 2 to the 
boundary cells.  
 
When you preprocess the data, the preprocessor calculates the model domain based on 
the .shp file and defines the model domain as a dfs2-grid with integer values 1 (internal 
point), 2 (boundary point) and zero values for areas outside the model domain. The pre-
processor assigns all of the model parameters based on the dfs2-grid that is calculated 
from the polygon that you have specified in this step. 
 
If you wish to change the model domain, all you have to do is modify the .shp file and pre-
process the data again. However, be aware that previously specified data must still cover 
the new polygon. If it does not, then either a warning will be issued (saying that some 
values were automatically interpolated) or an error will be issued (if it can't interpolate the 
data) 
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3.4.2 Add the .shp polygon to the overlays  

Go back to the Display item, and the Foreground Dialog: 

• Click on the Add Item icon,   

• Change the Type to Shape 

 
 
• Now, go to the new Shape:Unknown data tree item, and  

• Then click on the Browse icon,  

• In the Open file Dialog, find the file  
.\Model Inputs\GIS Data\catchment.shp 
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3.4.3 Adjust the display parameters for the .shp file 

In the Shape: catchment_meter.shp Dialog: 
 
• Choose line-colour 

• Increase the line thickness (e.g. 0.5 or 1 mm) 

 
 
Add more layers if desired. Line themes for showing the stream (karup_georef.shp) and 
observations boreholes (obswells.shp) are located in the same folder. 
 
Now in all of your map Dialogs, such as the Model Domain and Grid Dialog, the model 
domain should appear as a polyline on top of the map.  
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3.5 Set up the topography 

The surface topography is required for all MIKE SHE components. The model topography 
defines the upper bound of the groundwater model as well as the upper surface of the 
unsaturated zone model. It is also used as the flow surface for overland flow.  
 
Globally, Digital Elevation Model (DEM) data is widely available. Free DEM data at 90m 
and 30m resolution is available from the NASA SRTM data. There are also commercial 
providers of higher resolution DEM data, including DHI.   
 
For Denmark, DEM data at different resolutions (0.4m, 1.6m and 10m) are freely available 
from http://download.kortforsyningen.dk. Data is provided as raster grid data in ArcGIS or 
MapInfo format. For this model, the 10m-resolution DEM data was downloaded and 
resampled to 50m. The data was then converted to a point ArcGIS shapefile. 
 
The resampling can be important. High resolution DEM data will be interpolated in MIKE 
SHE. However, the GUI may become very slow if it is continually interpolating high-
resolution data.  

3.5.1 Define surface topography 

In the Topography Dialog: 
 
• Choose Point/Line (.shp) for the Spatial Distribution 

• Select the file  
.\Model Inputs\GIS Data\Topo-processed.shp 

• If the map is covered by black dots, click off the ‘Show shape raw data’ checkbox.  

 

• This will turn off the shape file data points. 

• The default interpolation method is Inverse Distance. Change the interpolation 
method to Bilinear 
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Spatially distributed data, such as topography can be specified using: 
• a Uniform value 
• a Grid file (.dfs2),  
• a Point/Line (.shp) ArcView or ArcGIS  map, or 
• an ASCII file with distributed xyz values (Point XYZ (.txt)). 

If a .shp file or a xyz-file is used, MIKE SHE will interpolate the data to the mesh defined 
in the Model Domain and Grid menu.  
 
Hint:  you can always see the Z-value at the cursor position at the bottom of your 
Graphical View. 
 
Point/Line - Interpolation method - You can choose between Bilinear, Triangular, 
Inverse Distance and Inverse Distance Squared interpolation methods by selecting from 
the Interpolation method combo box.  
• The Inverse distance methods are good for scattered data.  
• Bilinear Interpolation is a good method for interpolating from gridded data and the  
• Triangular method is good for interpolating from digitised contour lines.  
• You can use the Online Help to find out more information on the interpolation 

methods, by clicking F1. At the bottom of the Help page, are references to Related 
Items, which will take you to the detailed descriptions of the interpolation methods. 

 
SURFER - If you want to use interpolation methods not available in MIKE SHE, then you 
can use a program such as SURFER by Golden Software. In SURFER, you can save the 
interpolated SURFER grid to an XYZ file, and use the bilinear method in MIKE SHE to 
reproduce the Surfer interpolation. 
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ArcGIS Grid – If you have gridded data from ArcGIS, then you can use the Grd2Mike 
Tool (New File\MIKE ZERO\MIKE Zero Toolbox\GIS) to convert an ArcGIS grid to a dfs2 
file.  
 

 
 

Other tips: 
 
• The search radius should be sufficiently large to ensure that each grid gets a value. 

For this exercise 1000 m is sufficient. However, the minimum search radius is two 
times the cell size. Search radii below this will have no effect. In this data set, the 
data density is quite high, and changing the search radius will have no effect.  

• In some cases, such as when the grid is very large or the number of data points is 
large, then the interpolation can be time consuming. This can be a problem, since the 
grid is re-interpolated every time you enter the Dialog, as well as during the pre-
processing step. To make the model more efficient, you can save the interpolation to 
a dfs2 file for use directly. To do this, right click on the map view and select save to 
dfs2 file.  

• After you have saved the dfs2 file, you can then use it instead of the .shp file. Note 
though, that the link to the original .shp data is not lost, but simply hidden from view. 
This allows you to return to the original data if you want to change the discretisation 
of the dfs2 file, for example, if you change the size and shape of the Model Domain 
and Grid.  



 MIKE SHE 

30 Fully Integrated Exercises - © DHI 

• If you have high-resolution DEM data, often the most efficient process is to use 
ArcGIS to interpolate the DEM data to the grid resolution that you want to use. At the 
same time, ensure that the point values are located at the model nodes. This will limit 
the amount of re-interpolation in the GUI, and ensure that your model topography is 
exactly as you expect.  

3.6 Define climate 

3.6.1 Define precipitation rate and temporal distribution 

The precipitation is the actual amount of measured rainfall:  
 
• Go to Climate in the menu and select Precipitation Rate 

• For now, choose Uniform Spatial Distribution, which means that the same 
precipitation rate will be used all over the model domain. 

• Change the temporal distribution from constant to time varying. 

 

• Click on the  button to open the file browser 

• Scroll through the list and pick the file Precipitation.dfs0 

• Keep the default Item “Precipitation station 1” and click OK 
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The file browser lists of all of the files in your project that are the correct file type. The 
green check beside the file name indicates that the file contents match the data 
requirements – for example, the correct time period and units type. If you are in doubt, 

you can click on the  button will show you the data requirements.  
 
In this case, you are using spatially uniform recharge data. The precipitation file contains 
data from several rain gauges. The particular rain gauge to use is selected under the Item 
in the browse Dialog. In this case, you are using only the data from Precipitation station 1.  
 

 
 
In this model we are using a uniform rainfall rate over the entire catchment. For small 
catchments this is reasonable. In large catchments this would not normally be correct. By 
selecting Station-based, we can define regions or Theissen Polygons where different rain 
gauge data is used. If you have access to gridded rainfall data, for example from radar 
rainfall stations, then you can use fully distributed rainfall data as well.  
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Precipitation is specified the same way data is collected from rain gauges. It can be input 
as mean-step accumulated values (e.g. average rainfall per day in units of mm/day) or, as 
step accumulated values (e.g. measured rainfall in a tipping bucket rain gauge in units of 
mm since the last measurement). 
 
Finally, your calibration will depend on the frequency of your rainfall data. Your model will 
react very differently if you have monthly rainfall averages versus hourly rainfall from a 
local gauge. If you update your rainfall frequency, you will normally have to recalibrate 
your model.  

3.6.2 Add Reference Evapotranspiration 

MIKE SHE calculates actual evapotranspiration based on the evapotranspiration rate, the 
vegetation properties, and the soil moisture. 
 
In the Reference Evapotranspiration Dialog: 
 
• Use Uniform spatial distribution 

• Use Time-varying (.dfs0) Data Type  

• Use the browse button to select the file  
.\Model Inputs\Time\PotentialEvap.dfs0 

 

 
 
Reference evapotranspiration can be specified in the same manner as precipitation, that 
is as constant or time-varying values and as uniform or spatially distributed values. 
As you’re using Uniform distribution type, this evapotranspiration rate will be used 
throughout the model domain. 
 
Evapotranspiration and Precipitation are highly correlated. Reference evapotranspiration 
is a function of solar radiation (sunshine), wind speed, relative humidity, and air 
temperature. All of these factors are affected by rainfall. Thus, it is desirable, but not 
critical, to use Precipitation and Evapotranspiration from the same weather station and at 
the same recorded frequency.  
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3.7 Add land use 

3.7.1 Define the vegetation distribution 

• Under Land use select the Vegetation Dialog: 

• Use Station based Spatial distribution 

• Specify Grid Codes (dfs2) as the Data Type 

• Use the browse button to select the file 
.\Model Inputs\MAPS\Landuse.dfs2 

 
 
The map now displays your vegetation distribution. The map (dfs2 file) contains 4 different 
integer codes that define 4 different areas. You now need to define the vegetation types 
and growth function that are associated with the 4 different areas. 

3.7.2 Define vegetation types for each vegetation area 

Each of the 4 different vegetation areas in the vegetation map appears as a sub-item in 
the data tree. 
 
• Select the Grid code = 1 item 

• Change the ID to Grass 

• Set the Temporal Distribution to Vegetation property file  
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• Use the new items icon, , to add a line in the Crop Development table. 

• On the line in the Crop Development table 
- Use the browse button to select the vegetation property file (database file):  

.\Model Inputs\MIKE_SHE_vege.ETV 
 

- BEFORE closing the dialog,  
From the pull-down Veg type combo box pick Grass1 

 
 

 
 

- Set the Start date to 1. Jan. 2000 

(The start date is set before the simulation start data to ensure a full coverage of 
the simulation period). 
 

• Set the Recycling Mode to Each Entry 

For the remaining three vegetation types, set the Temporal Distribution to Constant and 
use the following values for the remaining items: 
• Grid code = 2: ID=Forest, LAI = 6,  RD = 800 [mm] 
• Grid code = 3: ID=Shrubs,LAI = 2,  RD = 500 [mm] 
• Grid code = 4: ID=Wetlands, LAI = 4, RD = 500 [mm] 
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The Crop Development table allows you to define flexible crop rotation schedules.  
The schedule is defined in the Vegetation database, and the Recycling Mode is used to 
define how the schedule is repeated during the simulation.  
 
The recycling mode defines what happens when the crop rotation ends.  
• If no recycling is defined, then the vegetation properties will revert to 0.  
• Each Entry means that each line in the table is repeated until the next start date. 
• Entire scheme means that the rotation table starts over again after the last entry. 
• Entries, then scheme means that the lines are repeated to fill in any gaps, and then 

the entire scheme is repeated.  

For example,  
• If you have one crop per year, then you can set up a simple annual schedule in the 

Vegetation database. Then if you choose the Each Entry option, the crop schedule 
will start over again as soon as it is finished.  This is what we have done here.  

• If you have multiple different crops per year, or a fallow crop in alternating years, 
then you could set this up as multiple lines in the Crop Development Table, with two 
different vegetation types and schedules.  

Note: The recycling does not account for leap years. So, if you have very long simulations  
that require precise crop rotation dates, then you may want to set up a 4 year cycle in the 
Vegetation database.  
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3.8 Add the river module 

You will now add an existing MIKE Hydro river setup to the model. Setting up the river in 
MIKE Hydro is detailed as a separate exercise in Section 5. 

3.8.1 Add the river module 

In the Rivers and Lakes Dialog: 
• Use the browse button to select the existing .mhydro file for the Karup catchment: 

.\Model Inputs\MIKE HYDRO\karup.mhydro 

 

3.9 Specify the overland flow parameters 

In the Overland Flow Dialog (in the MIKE SHE GUI), specify 
 
• Manning’s M equal to 2 [m1/3/s] 

• Detention storage equal to 4 [mm], and  

• Initial water depth equal to 0 [m]. 

 
 
The Karup catchment is quite sandy, and in this simulation there are no serious storm 
events. Thus, in reality, overland flow is insignificant for this simulation.  
 
You can disable overland flow by specifying a Manning’s M = 0 [m1/3/s]. Setting the 
Manning’s M to zero locally is sometimes a useful way of speeding up the simulation by 
turning off the overland flow calculation in areas of permanently ponded water, such as 
small reservoirs. However, a Manning’s M of zero will prevent any overland flow from 
entering the cell.  
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The Detention Storage defines the depth of ponding required before Overland Flow 
occurs. A high Detention Storage value will effectively turn off Overland Flow. Again, this 
is very useful when you want to locally turn off Overland Flow, for example in lakes or 
ponds.   
 
You can play with the Overland flow parameters later, if you like. 

3.10 Build the unsaturated zone model 

The unsaturated zone model calculates recharge to the groundwater model and is closely 
linked to the actual evapotranspiration, as the roots remove water from the unsaturated 
zone. Soil physical properties are stored in a soil-database. The link between soil-type 
distribution maps and soils in the soil-database are established similarly to the link 
between vegetation-distribution maps and vegetation types. 

3.10.1 Calculation column classification 

In the Unsaturated Flow Dialog: 
 
• Choose Calculated in all grid points (default) for the column classification type 

 
 
You should avoid Automatic UZ column classification and always use Calculated in 
all grid points.  
 
MIKE SHE allows you to lump similar UZ profiles together to reduce the computation time. 
In this case, the results of one column are copied to other similar columns. This option 
was very useful in the past when computers were slower. However, this should be 
avoided now. The option has been retained to support backwards compatibility and some 
special cases.  
 
Demo Note: You must use the Automatic Classification if you are using the demo 
version. In the Demo mode, the model size is restricted to a maximum of 155 UZ 
computational cells.  
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3.10.2 Define the soil profile distribution map 

In the Soil Profile Definitions Dialog: 
 
• Use Distributed for the Spatial Distribution 

• Use Grid codes (dfs2) distribution data type 

• Use the browse button to select the dfs2 grid file 
.\Model Inputs\MAPS\soil.dfs2 

 
 
The soil map contains three different code values, which now need to be associated with 
three soil profiles.  

3.10.3 Define soil profiles (horizons) 

Each of the 3 different soil areas in the soils map appears as a sub-item in the data tree. 
For each soil zone 
 
• Select the line in the Data Tree (Grid code 2, etc) 

• Set the Soil Profile depth to 41m 

• Use the browse button to select the UZ soil-database file 
.\Model Inputs\UNSODA basic soil classes.uzs 

• BEFORE clicking OK, select the soil type as follows:  

Grid Code = 2 Silt Loam 
Grid Code = 3 Loamy Sand 
Grid Code = 4  Loam 
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• Rename the Profile ID 

• Add 4 lines to the vertical discretization, using the add button  

• Set the vertical discretization as follows:  

 
 

 
 

To facilitate the process you can add four lines using the add button . Then select all 
the lines in the table (click in the upper right corner of the table). Then copy and paste the 
vertical discretization table into the other soil zones.  

 
The UNSODA database is a list of standard soil types developed by the US Department 
of Agriculture.  

3.10.4 DEMO MODE only: Define groundwater table for UZ classification  

Demo Note: If you are using the Demo mode, then you must use the Automatic 
classification method, which requires you to specify a water table  
 
The depth to the groundwater table is one of the criteria that are used when the automatic 
(lumped) unsaturated zone classification is used.  
 
• In the Unsaturated Flow dialog change the Classification Type to 1: Automatic  

• In the Groundwater depths used for UZ classification dialog specify Use initial water 
table for classification 

• Define 3 depth classes 1, 5 and 10 meters 
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3.11 Build the saturated zone model 

Before defining your computational layers you must input a geological model, which is 
defined as part of the saturated zone.  
 
A geological model may be defined as a combination of layers and lenses. Once the 
geological model is defined you may choose computational layers that are either identical 
to the geological layers or you may choose different computational layers. If the 
computational layers differ from the geological layers MIKE SHE’s pre-processor will 
transfer the hydraulic properties of the geological model to the computational mesh.  

3.11.1 Specify the Saturated zone (groundwater) options 

In the Saturated Zone dialog: 
 
• Select Include subsurface drainage. This will ensure that any springs drain to the 

streams. 
• There are no pumping wells for now, so make sure that the Include pumping wells is 

not selected.  
• Select Assign parameters via geological layers 
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The geology data can be assigned using both geological layers and geological units. If 
you choose the geological layers approach then the hydraulic properties are assigned as 
spatially distributed within the layer. If you use gridded data or point data, the hydraulic 
properties are smoothly interpolated to the model grid.  
 
If you chose the geological units approach, then you must specify a distribution of 
geological units for each geological layer, for example, by a polygon file. In this case, all 
of the model cells in each polygon are assigned a value for each of the hydraulic 
properties.   
 
The geologic units method is often specified when you use the AUTOCAL program for 
parameter estimation and automatic calibration. In this case, the parameters for each 
polygon can be estimated automatically and the model sensitivity for each parameter 
calculated.  

3.11.2 Define the number of geologic layers 

In this exercise, we will only have one numerical layer. 
 
In the Geological Layers dialog: 
 
• Keep the existing default layer name Aquifer 

By default there is already one layer in the model. Additional layers can be added by 

clicking on the Add Item icon, , deleted by clicking on the Delete Item icon, , or 

moved up and down by clicking on one of the Move Item icons,   

 
 
Each of the Geological layers includes one item in the data tree for each of the properties. 
Additional layers will add additional sets of items to the data tree.  
 
Increasing the number of saturated zone model layers allows you to better represent 
vertical flow and exchange between geologic layers. A fine vertical discretisation may also 
be required for solute transport simulations. 
 
MIKE SHE allows you to have any number of layers in the saturated zone. However, the 
more model layers you have, the higher the computational effort and the more memory is 
needed. If you need more layers, it is always better to start with a few layers and do the 
initial calibration. Then add layers as necessary, while ensuring that the model remains 
stable and computational effort remains reasonable. 
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3.11.3 Define layer bottom (lower level) 

In the Lower Level Dialog for Aquifer: 
• Select Point/Line (.shp) in the Spatial Distribution combo box 

• Using the file browse button, , select the file  
.\Model Inputs\GIS Data\layer1.shp 

• Untick the ‘Show shape raw data’ checkbox 

• Use the Bilinear interpolation method, and 

• Use a Search Radius of 1000m 

 

3.11.4 Assign hydraulic properties 

The remaining hydraulic properties are listed under the Lower Level item. For each item:  
 
• Select Uniform under the Spatial distribution combo box and specify the following 

values: 
 
- Horizontal hydraulic conductivity = 0.00026 [m/s] 
- Vertical Hydraulic Conductivity = 9.3e-5 [m/s] 
- Specific Yield = 0.2 [-] 
- Specific Storage = 0.0001 [1/m] 
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3.11.5 Define the subsurface drain reference system 

• Under Drainage, choose Drainage routed downhill based on grid codes 

 
 
Drainage routing can be a very complex process. Simply removing the water from the 
model is the simplest drainage option. However, in most situations, drainage actually 
discharges to the river system.  
 
Groundwater Drainage is a very powerful feature of MIKE SHE.  
• The simplest routing method for the drainage is to route it downhill based on the 

drain levels. The drainage will enter the river whenever it intersects a river link. 
However, this can lead to ponding in local depressions in flat terrains.  

 
• More complicated is the second option Drainage routing based on grid codes, where 

the drainage is routed downhill but only from certain cells. However, if you specify a 
single Drain Code, then the drainage will be to the nearest river.  

 
• The Distributed drainage options allow you to route drainage to specific MIKE 

HYDRO nodes or MIKE Urban sewer manholes.  
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3.11.6 Define groundwater drainage  

In the Drainage Level Dialog: 
• Select Uniform under Spatial Distribution  

• Use the value : -0.5 [m] (Note negative sign) 

• Check on “Values relative to ground” 

The Values relative to ground tells MIKE SHE that you have drains located 0.5 meter 
below ground surface in the entire model domain. If the groundwater table is higher than 
the drainage level drain flow will be produced and routed to a receiving cell or river. 
 
In the Time Constant Dialog: 
• Select Uniform under Spatial Distribution  

• Use the value = 5.6e-008 [1/s] 

In the Drain Codes Dialog 
• Select Uniform under Spatial Distribution  

• Set the Grid Code value = 1 

The drain time constant can be thought of as an empirical factor that accounts for the time 
it takes for the water to drain. For example, in the case of agricultural drains, the time 
constant could be affected by drain spacing, drain diameter, clogging, etc.  In the case of 
natural drainage, the time constant is affected by the distribution of drainage ditches and 
channels.  
 
A time constant closer to 1 implies that the water drains more quickly and the drain acts 
more like a constant head boundary, when the water table is above the drain level. 
Whereas, a value closer to 0 implies that the water drains more slowly. A value of 0 turns 
off the drainage.  
 
An Extra Parameter option is available for time varying drainage parameters. 

3.11.7 Define attributes of groundwater computational layers 

The computational layers are defined independently of the geological layers. While the 
Geological Layers have geological attributes, the Computational Layers include 
computational attributes such as initial conditions and boundary conditions. The 
properties of the geological layers are mapped and interpolated to the computational 
layers during the model preprocessing.  
 
Although, MIKE SHE allows you to define Computational Layers independent of your 
Geological Layers, in this exercise computational and geological layers will be identical. 
 
In the Computational Layers Dialog: 
• Select Defined by geological layers as the Type of Numerical Vertical Discretization 

• Use Minimum layer thickness = 0.5 [m] 
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The Minimum layer thickness is used to keep layers from crossing or completely pinching 
out, which would cause numerical difficulties. 

3.11.8 Define groundwater initial conditions 

In the Initial Potential Head Dialog: 
 
• Select Grid file (.dfs2) under Spatial Distribution 

• Using the file browse button, , select the file  
.\Model Inputs\Maps\init-head-500.dfs2 

 
 
You are using an initial head from a previous model run, which gives you a good starting 
point. In a real model, you might initially start from a value such as 3 m below the 
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topography. However, such a value will require a “run in time”, as the model may take 
several months to equilibrate.  
 
However, in most cases it is more effective to use a Hot Start. If you use a Hot Start, then 
the initial condition defined here is ignored.  
 
An alternative is to run the model as a steady-state simulation and then use the steady-
state solution as an initial condition. However, the steady state solution still might not be a 
reasonable starting point depending on how steady the groundwater table is. For 
example, the steady-state condition with pumping active might, in fact be nearly dry.  

3.11.9 Define groundwater boundary conditions 

The Outer Boundary is defined by the row of cells on the outside of the model domain. 
The outer boundary is defined by the Model domain and grid file, as all points with a code 
value of 2 (boundary point). 
 
In the Outer Boundary Dialog: 

• Press the Add Item Icon,  

• Select Zero Flux (default) as the boundary type  

• Click on the Add Point icon, , and click anywhere on the map 

 
 
This now gives you a no-flow boundary condition along the entire outside of the model. If 
the entire outer boundary is a no flow boundary, then this step is actually unnecessary 
because by default the outer boundary is no flow.   
 
The outside of the model can be divided into boundary sections, by clicking on the Add 
Item icon again. Then click on the Add Point icon, , again. Finally, click on the map 
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to define the location of the boundary point end point. The boundaries are specified 
clockwise around the model starting at the first point in the table. 
 
The outer boundary conditions are defined independent of the model grid. Thus, if you 
change your model grid the boundaries will be interpolated automatically to the new grid 
based on the nearest boundary cells to the point locations. If you change the shape or 
extent of the grid, you should check that your boundaries have not moved unexpectedly. 
 
Internal boundaries are used to specify such things as lakes and reservoirs that are not 
included in MIKE HYDRO River. In this case you could specify a constant head or a 
general head boundary for a lake.  
 
Internal boundaries are distinguished from outer boundaries because on the outside of 
the model, you can specify flux and gradient boundaries. 

3.12 Specify output options and calibration targets 

In MIKE SHE, there are 3 primary outputs:  
 
• Detailed time series – This is a point value of a MIKE SHE output at EVERY time 

step,for example, Depth of Ponding.  

• Gridded output – This is a 2D or 3D grid of values of a MIKE SHE output at every 
STORED time step, for example groundwater head elevation. 

• Detailed river time series – This is a point value of the water level or flow rate in the 
defined streams in the model. 

Both Detailed Time Series Output types automatically generate an HTML plot of the value 
as the simulation progresses. It also allows simulated output to be compared to observed 
output and calculates a number of statistics for model error. The HTML plots can be 
copied directly into reports.  
 
The Gridded output is stored less frequently to conserve space on your hard disk. 
Likewise, many gridded outputs are not saved by default. Gridded output is stored as dfs2 
(2D grid time-series files) or dfs3 (3D grid time-series files). If output data is stored too 
frequently, you may get very large and unwieldy result files. Thus, before running the 
simulation you should consider what and how often you need to save the data 
 
A time series can be created for any point in the model domain from the Gridded Output, 
but the frequency of the values will be the same as the Storing Timestep.  . 
 
More detail on evalutating the output is in the next step-by-step Exercise.  

3.12.1 Storing of results 

• Click on Storing of Water balance data 

• Set the Storing interval for grid series output to a daily frequency (24 hours) for 
Overland, Prec(ipitation) ET UZ, SZ-heads and SZ-fluxes. 
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The Water balance items are used during the post-processing of the results to calculate 
water exchanges between the various components 
 
The Hot start data is used for starting simulation from a previous result. This is useful 
when the run-in time for the simulation is long. In this case, you can run the initial 
simulation for a year or two. Then start subsequent simulations from a more reasonable 
initial condition. A good rule of thumb is to use a hot start condtion near the end of the dry 
season, when water levels are low and conditions are more stable.  
 

3.12.2 Define detailed time series output items 

• Select the Detailed timeseries output 

• Use the Add item icon, , to add 4 items to the list 

• For each item,  
- Set the name 
- Select head elevation in saturated zone under Data Type  
- Define the X, Y coordinates from the table below: 

Name X-coordinate Y-coordinate 

Obs 5 518003 6229169 

Obs 35 507700 6238357 

Obs 37 511408 6241637 

Obs 65 502766 6246299 

 
• Define the Depth = 5 

To add the observation data, you need to  
 
• Check on the Incl. Obs. Data checkbox 

• For each observation point,  
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- Use the browse button to select the file 
.\Model Inputs\Time\HeadObservations.dfs0 

- BEFORE clicking OK, you need to select the appropriate Item from the combo 
box. (e.g. Obs well 5 for the entry named Obs 5) 

-  

 
 

 
 

The X and Y location can be selected on the map using the  button. This is useful if 
you want to create a detailed output of specific output items at a critical locations.  
 
You are also welcome to add any other points and data items you like. 
 
The New Plot checkbox is used to define whether or not a new html plot is created during 
the simulation. For example, if you uncheck the first box, then the first two items will be 
plotted on the same graph.  
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3.12.3 Create a detailed time series for the MIKE HYDRO output 

MIKE View is used to evaluate the output from MIKE HYDRO River. However, MIKE SHE 
allows you to create a detailed time series with observations during the simulation, similar 
to the other MIKE SHE outputs.  
 
Add a detailed discharge time series to the end of the Karup River.  
 
• Under Storing of results select Detailed M11 timeseries output 

• Specify the name and location below:  

- Name: 20.05 (outlet) 
- Data type: Discharge 
- Branch name: Karup River 
- Chainage: 52000 
- Incl Obs: check 
- File name: .\Model Inputs\Time\flow.dfs0, and then select the item: 20.05 

 

 
 
To add a Detailed MIKE HYDRO River time series, you have to know the chainage of the 
h-point (for Water Level) or the q-point (for Discharge) ahead of time. If the value is not 
exact, then MIKE SHE will look for the nearest point, within a certain search radius. If 
there is no nearby point, then the output will be ignored. 

3.12.4 Select gridded outputs 

In the Grid series output Dialog many items will already be selected if you have turned on 
the storing of Water Balance data.  
 
• Some gridded items of interest are not connected to the water balance data. By 

clicking on the check box, turn on 
 
- 8. Actual evapotranspiration,  
- 30. Total Recharge to SZ, (negative) 
- 35. Water content in the unsaturated zone.and 
- 39. Depth to phreatic surface  
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End of the Exercise 
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4 Running and evaluating MIKE SHE Flow Model 

You can start this exercise by either loading a pre-defined MIKE SHE setup file, or using 
the model that you developed in the previous Chapter.  
 
If you are starting the exercises here, then  
• Use the Open icon to open the Karup_basic.she file 
 

   
 
This model should be similar to the model you would have obtained by following the step-
by-step instructions in the previous Chapter.  
 
In this exercise, the MIKE SHE filename is defined as YourFilename.she, as it may differ 
from the one that you are using.  
 
This exercise will familiarize you with the various output functions in MIKE SHE. However, 
the exercise will guide you through only the most basic functionality of the tools, including 
the Result Viewer, the Plot Composer, and the Water Balance tool 

4.1 Pre-process the data 

You have now specified all the input required for the model. Up to this point, all of the 
input data has been specified independently of the numerical model. You have specified 
only the characteristics of the numerical model that will be run.  
 
Before actually running the model, you must run the Pre-Processor. The Pre-Processor 
extracts all of the spatial data that you have included and builds the actual model files.  

4.1.1 Run the preprocessor 

Click on the  icon to start the Pre-Processor. 
 

 
 
The preprocessor will start the MIKE Zero Launch utility. 
• Click OK 
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Upon successful completion of the Pre-processing, you should check the model pre-
processor log file to ensure the pre-processing finished without any errors. If the Pre-
processing did fail, then the log file should contain some information to help you locate the 
problem. 
 
The Pre-processed log files are by default located in the Result folder under MIKE SHE 
exercises.   
 
• Go to the results in Result\YourFilename.she - Result Files folder and double click 

on YourFilename_PP_Print.log (the file should open in Textpad) 

Scroll to the bottom of the file and check that the last line to ensure that the Pre-
processing was successful.  

4.1.2 View the preprocessed data 

After successfully running the Preprocessor, 
• Click on the Processed Data Tab located at the bottom of the Navigation Tree.  

• Then, click on the items in the data tree and explore the processed data.  
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The pre-processor creates a .fif file that contains the cell values etc. that will be used in 
the simulation. The processed data has been interpolated to the computational mesh, 
exactly as the simulation engine will read it. However, the .fif file is a binary format 
optimised for use by the numerical engine.  
 
The .fif file embeds all geometric data. Temporal data (time-series data) are not contained 
in the .fif file, but are read directly from the source data files during the simulation. 
 
To view the pre-processed data, a parallel set of .dfs2 and .dfs3 files are also created so 
that the standard MIKE Zero tools can be used to view the data.  
 
It is the dfs data that is shown in the data tree and listed in the file name text box. Clicking 
on the View button opens the Grid Editor with the current pre-processed data file loaded – 
with all the current overlays.  
 
Spend some time moving around in the Processed Data and make sure you understand 
the input data and the relation between Setup Data and Processed Data.  
 
If you want to change any of the values in the Processed Data, you cannot just change 
the values in the Grid Editor. The values that you see are not the ones that will be used in 
the simulation. Therefore to change the values you have to: 
• Edit the values in the Grid Editor, 
• Save the parameter to a new dfs2 file, and  
• Then edit the Setup tab parameter to read from the new dfs2 file that you created.   

4.1.3 View the river link setup 

The MIKE HYDRO network is interpolated to the cell boundaries of the model grid. The 
interpolated river locations are called river links. 
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In the Processed Data Tab the most recent pre-processed file is automatically loaded 
 
• Go to the River Links Item in the data tree to view the pre-processed river links: 
 
• View the location of the river links in the computational mesh. 

 
 
A .shp file of the River Links is also automatically created during the pre-processing. This 
file can be loaded as a background map in MIKE SHE, or in any of the MIKE Zero display 
tools, such as the Grid Editor, Plot Composer, and Results Viewer.  

4.1.4 View the river bank elevations vs topography 

A mismatch between the topography and the bank elevations will sometimes lead to poor 
OL-River exchange. You can use this item to locate areas were bank elevations are 
poorly matched to the topography. Occasional, random areas of mismatch are OK. 
 
In MIKE HYDRO, you specified cross-sections. Each of the cross-sections includes a left 
and right bank elevation. These elevations define how the river interacts with Overland 
flow.  
• Overland flow will only flow into the river if the water level on the land surface is 

higher than the bank elevation (and higher than the river level).  

• If overbank spilling is allowed (Default = off), the river will only spill on to the flood 
plain if the river water level is higher than the bank and higher than the topography.  

If water ponds along the edge of your river, it will normally infiltrate and enter the river via 
baseflow.  
 
A poor match in the elevation is sometimes a sign that your cross-sections are much 
wider than your cell size. Typically, the elevation rises away from the river, and if you 
define cross sections much wider than the river, then you risk having the bank elevations 
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defined many metres too high. A good rule of thumb is to define your cross-sections as 
the normal bank full level.  
 
If your bank-full cross-sections are much wider than your cell size, or if you want to 
simulate large innundated areas, then you may want to use the Flood Code option.  
 

 

4.2 Run the simulation 

In the Toolbar, click on the Water Movement  icon to run the simulation.  
This will start the MIKE Zero Launch utility.  
• Click OK 

 



 MIKE SHE 

58 Fully Integrated Exercises - © DHI 

The Launch utility allows you to change the CPU Priority and the Results Folder prior to 
the start of your simulation.  
 
You can also change the CPU Priority during the simulation by clicking on the yellow 
button in the lower right corner of the user interface. You can stop the simulation entirely 
by clicking on the red button.  
 

 

4.3 View the results 

Upon successful execution of the model you are now ready to view the results. First you 
should check the model run log files to ensure the model finished without any errors. The 
result files and log files are by default located in the Result folder under MIKE SHE 
exercises.   
• Go to the results in Result\YourFilename.she - Result Files folder and double click 

on YourFilename_WM_Print.log 

• Scroll to the bottom of the file and check whether the different model components 
converged. Note that maximum iterations for some of the components may have 
been exceeded. This could be an indication of mass balance errors and we will 
check this when we create the water balance. 

4.3.1 Locate the detailed time series output results  

After successfully running the model: 
• Click on the Results Tab located at the bottom of the Navigation Tree and select 

MIKE SHE Detailed Time Series. 
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All of the observations should also be visible. 
 
You can add additional detailed time series items now and re-run the model.  
 
The MIKE SHE Detailed Time Series output Dialog, under Simulation Results, lists the 
Detailed Time Series results you have chosen to store during the MIKE SHE simulation.  
 
If you have specified more than 5 items for detailed time series output, then you will only 
see a page of links on the main Detailed time series page. The links will direct you to 
separate .html files with 5 graphs in each. 
 
To plot multiple items on a graph, you can use the New Plot column in the Setup to 
combine output in one graph. If you unclick the checkbox, then this item will be plotted on 
the same graph as the previous item.  

 

4.3.2 Locate the MIKE HYDRO detailed time series output results  

Similar to the groundwater levels, find the MIKE HYDRO (MIKE 11) detailed time series 
 

 

4.3.3 Plot flows using the Plot Composer 

It can sometimes be difficult to see how well the model fits the observations on this graph. 
Alternatively try to use the Plot Composer for viewing the modelled and observed flow 
hydrographs. 
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• To open the Plot Composer click New File on the main menu at the top below File 

• Select the Plot Composer 

 
 
• Click Plot->Insert New Plot Object and select Time Series Plot 

• Click New Item  and browse to the result folder YourFilename.she - Result 
Files. Select  YourFilenameDetailed_M11.dfs0 

• Click New Item again and add the observed flow data .\Model 
Inputs\Time\flow.dfs0 

• Click OK 

• To change the appearance of the graphs, right click on the graphs and select 
Properties. Click Curves and change line colours and markers 

• To save the graph as an image click View->Export Graphics->Save to Bitmap 

• Save the plot composer file in the Model folder as Flow.plc  
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4.3.4 Display the gridded results 

The Gridded Data Results Viewer dialog lists the results you have chosen to store in the 
MIKE SHE results files. The XY flow vectors check box adds groundwater velocity flow 
vectors calculated for each cell.  
 
The Layer no for groundwater items is used to select the numerical SZ layer number in 
groundwater outputs. 
 
• In the head elevation in the saturated zone item, check on the Add XY flow vectors 

for the plot and then click on the View result… button 

 
 
Note that the velocity vectors will not appear in the initial time step, but rather appear 
first in the second time step.  
 
On the menu at the top: 
 

  
 
you can play through the entire simulation, change the time step or create a video. 

To step through the simulation click on  on the menu. 
 
Note: Creating an .avi video is very time consuming, so don’t start the video creation 
process during a course.  
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4.3.5 Display a time series plot at a point 

To view time series in points go back to the Gridded Data Results Viewer 
 
• Click View Result… for head elevation in saturated zone. Untick Add XY-flow vectors 

if these are ticked 

• Click on the Time Series button  on the Results Viewer tool bar  

• Click once inside the map area and then while holding down the Ctrl-key, click on 
each additional point where you want time series output. Each selected locations is 
marked with a yellow x. 

• Double click on the last point. (if you only want one point then simple double click 
without holding down the Ctrl-key)  

• Check Display and press OK to display the time series. 
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Export to a dfs0 file 
 
• Right-click in the time series plot. 
• Select Export… in the pop-up window. 
• Check Export and press OK. 
• Enter an appropriate file name for the dfs0 file and press Save.  

  
 
The (j,k) coordinates listed at the bottom of the Results Viewer go from 0 to (nx-1) and 0 
to (ny-1) in the j and k directions, respectively. 
 
Note that the time series time steps are equal to the storing time steps. The Detailed 
timeseries output option within the Setup Data saves the output at every time step.  

4.3.6 Extract a profile of water levels  

• Press the button  on the Results Viewer tool bar to extract a profile from the 
simulate output item displayed 

• Click in the area of interest to select the points along the profile line. Double click on 
the last point of the profile to terminate the profile line. The profile line is indicated 
with a thick green line.   

Check 3D head elevation in saturated zone and press OK. 
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To display the computational grid on the profile, in the Projects pull-down menu choose  
 
•   Active View Settings -> Profile… 

On the Graphical Items tab of the Dialog that appears, under Calculation layers,  
 
• Check Draw Calculation layer and select Draw as grid to show the computational grid 

or Draw as lines to show the upper and lower surface. 

• Press OK to view the selection 
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4.3.7 Modify visible overlays and display the finite difference mesh in result viewer 

First, return to the horizontal view of head elevation in saturated zone, by either closing 
the cross-section view or switching via the Window pull-down menu 
 
• In the Projects pull-down menu choose Active View Settings -> Horizontal … 
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In the Dialog that appears 
 
• Single click on the Rectangular Grid item:  YourFilename_3DSZ.dfs3 to view the 

available display options 

• Under the Miscellaneous items, check Element Mesh 

• Press OK to execute changes 
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4.3.8 Display other gridded data results 

The number of gridded data items that are available depends on which modules were run 
and what selections you have made in the Setup. Many of these items are very useful for 
evaluating the integrated groundwater surface water interaction. You should explore some 
of these output items. For example: 
 
• Actual evapotranspiration – this is the sum of all the ET components. It is useful for 

evaluating the spatial distribution of actual ET.  

• Depth of overland water –typically this is a useful output for finding areas with 
permanently ponded water, or areas with closed depressions. 

• Seepage flow SZ – overland – this can be used for determining where springs are 
occurring in the model. 

• SZ exchange flow with river – this is useful to find losing and gaining river reaches.  

• SZ drainage flow from point – this output maps the locations where groundwater is 
contributing water to the SZ drainage network.  

• Total Recharge to SZ – this is a summary output map of all the items that contribute 
inflow to the SZ. 

4.4 View simulation statistics 

Statistics used for assessing the model fit are available in the Results menu under Post-
Processing. The statistics are generated in HTML file format and include all the detailed 
time series items that have observation data.   
 
The calibration statistics available comprise six standard statistics: 
Mean (ME), Mean Absolute Error (MAE), Root Mean Square Error (RMSE), Standard 
Deviation of the Residuals (STDRes), Correlation Coefficient (R) and Nash Sutcliffe 
Correlation Coefficient (R2). 
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The equations for calculating the statistics are included in the Help menu and can be 
accessed by pressing the F1 key while placing the cursor over the Post-Processing menu 
 

 
  
Note that the statistics are calculated based on the differences between the measured 
observations and the simulated values at the time of the observations. 
 
• To generate statistics for the Karup model click Post-Processing->Simulation 

Statistics and click the generate statistics button  

• Change the dates if statistics for a shorter period than the full simulation period are 
needed 

• Take a look at the statistics and assess the model performance 
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4.5 Check the water balance 

The water balance utility in MIKE SHE is a vital part of the results analysis. The tool is 
versatile and can be used both for providing an overview of component inflows, inflows 
and storage changes over different periods and subcatchments and for troubleshooting 
any numerical issues. 

4.5.1 Create a new water balance document 

• Click on the New document icon, , or the File/New/File menu 

• Select MIKE SHE and then the Water Balance Calculation (.wbl) document  

• Click OK 

 
 
• In the Project Explorer select the directory where you want to save the document, for 

example your model result folder: Result\YourFilename.she – Result Files 

• Then give the file a name (e.g. SZWaterbalance) and click on the Save icon,  
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In MIKE SHE, water balances are calculated by the water balance utility. This is run 
separately after the simulation. Creating a water balance involves 3 steps: 
 
1. Extract the water balance data from the MIKE SHE output files 
2. Create specific water balances from the extracted data 
3. Evaluate the water balance output  

4.5.2 Extract the water balance data 

• Use the browse button and find the .sheres file from your simulation in your Result 
directory Result\YourFilename.she - Result Files 

• Run the water balance extraction by clicking on the Extraction icon,  or by 
selecting the drop down window Run and clicking on Extraction. If the extraction icon 
does not appear at all, most likely the Run toolbar is not activated. Select the drop 
down window View, Toolbars and select the Run toolbar (last entry). 

• Check to make sure that the Extraction ran successfully, by looking for “Normal 
termination” in the message window 

 
 
MIKE SHE saves the results in many different files. The results are grouped by process 
(e.g. OL, UZ, SZ) and by output type (i.e. 2D or 3D). The extraction process reads all of 
the various output files and builds a set of water balance files. These files can be 
efficiently read by the water balance utility.  
 
The .sheres file is an ASCII catalogue of all the output files associated with the simulation.  
 
The type of extraction is important, as it defines what subsequent water balances can be 
calculated. 
 



Running and evaluating MIKE SHE Flow Model  

 71 

• Area Type – Choosing subcatchment allows you to create water balances for sub-
areas in the model domain. Otherwise, the water balance is for the entire model 
area. 

• Resolution type – By default the water balance is for the entire catchment or sub-
catchment. The Single-cell option allows you to create maps of some of the water 
balance items. 

4.5.3 Create water balance items 

• On the Postprocessing tab, add two post processing items to the table by clicking on 

the new item icon,  

• Change the name of the two items, so that you can distinguish them from one 
another 

You can set up any number of water balance calculations for a single water balance 
extraction. Since these are all stored in the water balance document (.wbl file), you can 
re-run the water balance extraction and processing after each simulation.  
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4.5.4 Define a Chart water balance 

• Select Chart output: Total water balance from the list of available Water balance 
types  

• Define a file name for the output file, for example TotalWB.txt. If you just type the 
name the program will automatically put it in the result folder  

• Run the water balance by clicking on the water balance icon run selected 

postprocessing,  

 
 
The Chart output creates a graphic illustrating the water balance items (see next step). 
The output is sent to an ASCII .txt file, and the graphic is generated automatically by a 
utility that reads the txt file.  
 
By default, the water balance is summed for the entire simulation period. However, you 
can easily change the water balance period, for example, to create seasonal water 
balances, or to remove the initialisation period.  
 
If you defined the extraction on a sub-catchment basis, then you can select from the 
available sub-catchments in this Dialog.  
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4.5.5 View the water balance output 

• On the Result tab, select the sub-item for the Chart output 

• Click on the Open button beside the file path to create and open the water balance 
graphic 

• To save the chart as an image file click File->Save Graphics… and select either 
Enhanced Metafiles (.emf) or Bitmap Files (.bmp) 

 
 
The water balance graphic shown for the full model simulation period includes all of the 
non-zero water balance items in the current simulation (except for storage changes, which 
are always plotted).  
 
The water balance items are all normalised to units of mm, which allows for easy 
comparison between the different components. If you want to convert depths of mm to 
volumes, you need to multiply the depth by the internal model area. That is, the total 
model area minus the area of the outer boundary cells. If you load the pre-processed data 
into the Grid Editor, select the Model and Domain item. Then, you can use the statistics 
function in the Grid Editor to find out the number of internal versus external cells. 
 
Note: The sum of the water balance terms in the graphic do not add to zero. This is 
because some of the signs have been removed (e.g. Precipitation and ET have the same 
sign, but opposite inflow/outflow directions). In the water balance calculation, inflows are 
negative and outflows and storage increases are positive.  
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4.5.6 Define a time varying water balance 

• Return to the Post-processing tab and select the second water balance item 

• Select Total water balance from the list of available water balance types 

• Leave the Output type as Accumulated 

• Select the Output file type as a Time series file 

• Input a filename with the .dfs0 extension, for example TotalWB.dfs0 and click on the 
browse button to specify the location where the file should be saved 

• Run the water balance by clicking on the run water balance icon  

 
 
 If you chose the Table format for the Output file instead, then the output will be in a tab-
delimited ASCII file that you can open in Excel.  
 
In this exercise we have chosen an Accumulated water balance. This sums the water 
balance over the simulation period.  
 
The alternative is to define an incremental water balance, which outputs the water 
balance time series at each saved time step.  
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4.5.7 View the water balance output 

• On the Result tab, select the sub-item for the time series output, Time varying water 
balance 

• Click on the Open button beside the file path to create and open the water balance 
time series file (.dfs0) 

 

 
 
The water balance time series file includes all of the available water balance items – most 
of which are also shown on the chart of the total water balance.  
 
The cumulative water balance sums the items over all of the stored time steps. Scrolling 
to the bottom of the file the total precipitation is the same as in the graphical total water 
balance chart above. Some items have been lumped together in the chart. 
 
Note, that the sign of the precipitation is negative and ET is positive in the time series file. 
This is consistent with the water balance sign convention which is:  
• Outflow – Inflow + StorageChange = 0 

Thus,  
• All inflows to the model our negative 
• All outflows from the model are positive 
• A negative change in storage means that water is accumulating (an ‘Inflow’) 
• A positive change in storage means that water is draining (an ‘Outflow’).  

One important thing to remember is that the water balance is only an output of the saved 
time steps. Thus, the dynamics between the saved time steps are lost. 

End of the Exercise 
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5 Building a MIKE HYDRO Model for MIKE SHE 

The purpose of this exercise is to get to know MIKE HYDRO by inspecting and 
completing a MIKE HYDRO river model for a MIKE SHE model. The model is based on 
the stream model for Karup used in the Karup integrated MIKE SHE exercise. The 
exercise covers the following topics: 
• Adding a river branch and boundary conditions 
• Generating cross-sections from a DEM 
• Routing vs dynamic branches 
• Adding a weir 
• Model stability 
• Using MIKE View for result processing 

5.1 Open the MIKE HYDRO model setup file 

Ensure that you have installed the Example files in the previous Getting Started exercise, 
and have opened the MIKE SHE exercises.mzp project file.  
 
• In the project explorer on the right hand side, locate 

.\Karup_Mhydro\karup_v1.mhydro 

• Open the model by double clicking on the file. This could take a few seconds. 

 
The MIKE HYDRO interface is similar to the MIKE SHE interface, but is more map-
oriented. It includes all the model settings and parameters on the left pane. 
 
A map of the river setup is shown in the middle window. It is possible to shift between the 
map and tabulated values by clicking Map or Tabular in the bottom left corner of the map 
window. 
  
Model components can be selected either on the left pane or by clicking the tabs above 
the map window. Details of the model components are shown in the pane to the right of 
the map window. 
 
Icons for zooming in/out and for inspection of stream parameter values are available from 
the toolbar above the map. 
 
A Validation pane at the bottom shows any data input errors in  setup. 
 
• Click Zoom to working area for a visual inspection of the river setup 
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On the left pane the Simulation specification menu allows you to select the type of 
modules to include in the model setup. In this case the river module and a hydrodynamic 
model run have been selected. Depending on the selections, different data input menus 
will be available below. 
 
• The simulation period and time control are also specified here. However for a MIKE 

SHE model run the simulation period is overridden by the simulation period specified 
in the MIKE SHE menu (see ).  

• Map configuration allows you to specify the coordinate system and include 
background maps. 

• River network includes details of the river network including control structures. 
• Hydrodynamic parameters contains the bed resistance.  
• Boundary conditions include boundary conditions and specification of coupling with 

MIKE SHE. 
• Initial conditions allows for initial flows and water levels to be specified. 
• The Results specification menu allows you to set the output file name and storing 

frequency for the output. In dynamic simulations the time step for MIKE HYDRO river 
can be quite small, so it is often necessary to reduce the storing frequency. 

5.1.1 Set the results directory 

The current results directory can be changed under Result specification->Standard results 
 
• Ensure that Use default result folder is ticked  

This will create a result folder using the MIKE HYDRO name: karup_v1.mhydro – Result 
Files with the results in the Result folder located under MIKE SHE exercises. You can 
select a user defined folder instead but make sure you use a sensible name. 
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• Leave the result file name unchanged 

 

5.2 Explore the branch network and add a branch 

On the Setup pane select River network -> Branches or click the Branches menu above 
the map.  
 
• Inspect the stream network in the map view.  

The appearance of the river can be modified by switching from the Setup pane to the 
Symbology pane on the bottom left. Select Tabular view to change symbols and labels. 
 

 
 

Hauge creek 



 MIKE SHE 

80 Fully Integrated Exercises - © DHI 

One tributary named Hauge creek is currently missing in the river setup. The river 
branches are shown on the background map as blue lines. 
 
• Add the missing branch by clicking File -> Import -> Import from Shapefile. Select  

.\GIS-Data\Hauge_creek.shp  

• Tick Branches and in the combo boxes define the attributes for Branch name, Topo-
ID, Start and End chainage, Chainage unit, Flow direction and Branch type.  

 
 

• Click Run, then OK, then Close 

5.2.1 Convert the branch from Dynamic to Routing 

• Select Tabular to view the branch details. 

• Change Hauge creek from a Regular branch to a Routing branch in the Branch Type 
menu in the Tabular view 

 
 
A regular branch will calculate the water level based on the Saint-Venant equation 
(Kinematic, Diffusion or Dynamic Wave formulations). For detailed simulations, you would 
generally use regular branches. 
 
However, often it is convenient to use simpler routing formulations, where the water in the 
river is moved down the river – without actually calculating the water levels. Water levels 
are calculated afterwards knowing the flow rate in the cross-section and back-calculating 
a water level. 
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The main advantage of the routing methods is their speed. They require less data, they 
are numerically stable and you can use very long time steps if you want.  
 
The downside is that the calculated water levels are less precise and hydrodynamic 
effects are ignored. Water levels are simply calculated based on the amount of water in 
the river in the current time step.  
 
You may also combine different approaches, for instance by using simple routing 
techniques on the upstream, steep branches and the dynamic wave approaches on the 
downstream low-gradient branches. 
 
For simplicity and to ensure the model runs fast the existing branches have all been set 
as routing branches. 

5.2.2 Connect the branch to the Karup River 

Return to the map view and  
• Zoom to the confluence with the dragging zoom function in the icon bar 

 

• Connect the branch to Karup River by clicking the Add/Edit connnection button , 
then clicking on the end of the Hauge Creek branch and dragging the cursor over to 
the Karup River (you will see a cross appear on the Hauge Creek, and then a large 
dot when you are over the Karup River) 

• Now, go to Tabular view and change the down stream connection chainage for 
Hauge creek to chainage 28600 (the location of a cross section) 

 

5.2.3 Routing methods 

To view the routing method parameters go to River network -> Routing method Dialog. 
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• On the last entry select Hauge creek and specify a chainage of 12090. No other 

changes are required. 

In the Routing Method Dialog you only need to specify a chainage close to the end of the 
branch. If no other specifications are made, the model will: 
 
• Calculate water levels using the Manning Equation assuming that the energy slope 

equals the bed slope derived from cross-sections (Manning numbers are specified in 
the HD11 file default is M=30 [m1/3/s], n=1/M). 

• Use the No-Discharge Transformation option, which implies that inflows are summed 
along the branch and transferred to the downstream end of the branch in the same 
time-step. This is the same as a full pipe with a unit of water entering one end and 
pushing a unit out the far end.  

• Another discharge computation option is the Muskingum methods. It dampens the 
peak flows as they travel downstream, which is necessary when the travel time in the 
river is much longer than the time step. For example, in large river networks, it may 
take several days or longer for a flood wave to travel from the source to the river 
mouth. 

 
 
Note: In the routing option calculations are only performed at cross section locations. The 
Maximum dx = 5000 m specified in the Simulations specifications->Comp control 
parameters on the Grid spacing tab is not used. You may include additional routing points 
at different locations along a branch, but this will not be covered in this course. 
 
In this exercise, you are using the simplest option, where no routing is used. Thus, 
whatever water flows into the branch network at the boundaries or as lateral inflow, will be 
transferred downstream in the same time-step.  
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MIKE SHE keeps track of and conserves mass and does not allow water to infiltrate from 
the river to the groundwater if the river is empty. 

5.3 View and add cross-sections from a DEM 

Cross section data can be viewed either by selecting Cross sections under River network  
and then Tabular view directly or by selecting a specific cross-section on the map and 
then switching to Tabular view. Cross sections are displayed with blue on the map and 
below the cross section in Bording Creek, chainage 0 has been selected (light blue). 
 
Note: The cross section may be difficult to see with the default symbol (black line). It may 
therefore be necessary to change the Symbology to show the cross sections with dots 
first. 
 

 
 
Cross-sections are saved to a cross-section file .xns11 (see the General tab) which can 
also be viewed and edited using the MIKE11 editor. To view the file in the editor double-
click on the cross section file in Project Explorer. 
 
In the cross-section dialog,  
• Cross-sections are identified by a Branch ID and a TOPO ID 
• Cross-section data are relative to the specified Datum value 
• Cross-section data are editable in the table 
• The marker values in the table define the extent of the cross-section to be used in 

the simulation 
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Cross-sections for Hauge creek need to be added to the model setup. Survey data are 
not available but a detailed Digital Terrain Model (DTM) with a resolution of 1.6 m, 
available from http://download.kortforsyningen.dk can be used instead. For this exercise 
the DTM was resampled to 3.2 m to keep the file to a reasonable size. Note the example 
cross-section file included with the training material was generated using the original file 
with the fine resolution. 
 
• First, set the coordinate system: ETRS_1989_UTM_Zone_32N. If you load the file 

first, the DEM may be invisible. In that case select Symbology and turn the colours 
back on.     

• Load the elevation model by selecting Map configurations->Digital Elevation Model 
(DEM) on the left pane and select .\GIS data\dtm_hauge_clp.asc. This may take a 
a few seconds as the file is large.  

• Tick on the Use DEM for  

 
 
• Click Map to view the DEM. 

Branch ID

TOPO ID

Markers

Datum
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A DEM can be defined in two file formats either as a ESRI ASCII or a dfs2 file. For ESRI 
ASCII files the coordinate system and z unit for the file must be specified. If a .dfs2 is 
chosen these parameters are taken from the dfs2 file definitions. 
 
By ticking Use DEM for cross section digitisation different options are available in terms of 
interpolation and number of points to extract per cross-section. 
 
It is also possible to set additional parameters for using the DEM for river tracing and 
catchment delineation. 
 
• To extract cross sections for Hauge creek select Tools->Auto generate cross 

sections… from the Tools menu 

• Specify an interval of 3000 m and a width of 100 m. Tick Use bilinear interpolation 

• Click Generate and close the window 
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• Click on the Map to view the location and length of the cross-sections. 

• In Tabular view click General -> Recompute all to compute processed data for the 
new cross sections 

• Before saving the model save the cross section file using a different name. Go to the 
project explorer, right click on karup0.xns11, copy it, and then change the name to 
karup1.xns11.  

• Go back to MIKE HYDRO and select karup1.xns11 in Cross sections -> Tabular 
view 
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The cross sections are too wide and only the main channel geometry should be included 
in the model. To constrain the extent of the cross section used in the simulation the bank 
markers will have to be moved. This can be done in different ways. Embankment lines 
can be added either by importing them as shapefiles or by digitising them in MIKE 
HYDRO. Alternatively the markers can be modified manually either directly in MIKE 
HYDRO or by using the older MIKE 11 cross section editor. 

For this exercise the cross sections will be modified in MIKE HYDRO: 

• Go to River network->Cross sections and select the Tabular view window 

• Click Hauge creek/model cross and select chainage 0 

• On the Cross section properties menu select Raw data 

• Click on a point  under Marker and click OK. The selected point will be shown in 
red on the graph (see below) 

• Hauge creek is quite small and the DEM is not sufficiently detailed to include the 
channel everywhere. As a guide set the width to app. 5-20 m. 

• It may be necessary to click on several points to find the correct location. Once the 
left bank has been identified tick (1) Left levee mark  

• Do the same for the bottom of the stream (2 Lowest point/River alignment) and right 
bank (3 Right levee bank) 

• Repeat the process for all the cross-sections in Hauge creek 

• Once all the markers have been set, save the MIKE HYDRO project.  
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Note: In Hauge creek the cross-sections are now located very close together at the 
confluence with a distance of 100 m. This is fine for using the simple routing method but 
for a fully hydrodynamic run this could mean that the model becomes unstable. In that 
case it may be preferable to remove the cross section at chainage 12000.  

5.4 Add boundary conditions 

Boundaries can be viewed either by selecting Standard boundaries directly or by selecting 
a boundary point on the map and then switching to Tabular view. The boundaries are 
shown with red dots on the map. 
 
Now take a quick look at the boundary specifications in the model. All the upstream ends 
(Chainage = 0) are defined as Inflow boundaries with zero inflow. The downstream mouth 
of the river is defined as a water level boundary. 
 
• Add another Inflow boundary for Hauge creek (Chainage = 0) with zero inflow by 

selecting Add   boundaries on the Boundary menu above the map and clicking on 
the upstream end of the branch in the Map window 

• Select Tabular and change the type from Water level to Discharge 

• Specify a small discharge of 0.005 m3/s. This will reduce the risk of the model 
running dry 

Specifying a small influx as a boundary condition will prevent the model from running dry 
and will also keep the model more stable. This is only an issue when using a regular 
branch with Kinematic, Diffusion or Dynamic Wave formulations. 

5.5 MIKE HYDRO – MIKE SHE coupling 

In the Boundary conditions -> MIKE SHE Couplings Dialog, you specify which MIKE 
HYDRO branches will be coupled with MIKE SHE. You may choose to include some of 
the river branches or all of them, or even just part of a branch. 
 

• Add Hauge creek by clicking  in Tabular view and select Hauge creek   

• Change DS chainage to 12100 to couple the full length of the branch to MIKE SHE 

• Change the conductance option to River bed only and set the leakage coefficient to 
10-6 sec-1 

The coupling specification includes the definition of the river-aquifer exchange, including 
the river bed leakage coefficient. The river leakage can also depend on the hydraulic 
conductivity of the aquifer material when the MIKE SHE cell size is much bigger than the 
river width. 
  
The exchange between MIKE SHE and MIKE HYDRO is one-way (default setting). 
Overland surface water will flow into the MIKE river, but water will not flow back onto the 
ground surface if the river floods. Overland flooding can be included, using one of two 
options:  
 
• Cells can be defined by flood codes, where they will be flooded if the elevation of the 

MIKE SHE cell is below the water level in the nearest river H-point. 
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• Alternatively, you can allow overbank spilling. In this case, the river will discharge the 
water onto the ground surface based on a weir formula.  

 

5.6 Run a simulation 

To test that the model has been set up correctly, it is necessary to run the model.  
 
• Run the model by selecting Run->Simulation from the main menu 

• Inspect the run messages on the Simulation pane and make sure the model run 
finished without errors 

To test the performance of the MIKE HYDRO model without MIKE SHE it is necessary to 
run the model with some inflows at the boundaries. For a simple routing model, simply 
running and checking the model will mostly be sufficient. 
 
For a fully hydrodynamic solution it is sometimes necessary to run it with an inflow 
hydrograph upstream in order to test whether the model is stable for the full flow range. It 
is also recommended to generate a result file with small boundary inflows that can be 
used as a HOT-start file to prevent initial instabilities. 
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5.7 View the results 

To check the model results, open MIKE View by going to the Start menu and select MIKE 
View 2017->MIKE View 
 
• Load the results by selecting the file type as .res1d and the select your latest 

simulation results.  
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• Click  to select and plot a time series of discharge at the downstream confluence. 

This should show a constant stream flow of 0.025 m3/s 

• Click  and select a branch to plot a cross section showing the water level. Click 
on the branches you want to view and press the Ctrl key and click in the view to 
complete the cross sectional plot 

• Click  to run through the simulation and  to pause at a desired time  
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5.8 Add a weir structure 

You will now add a weir to the main branch Karup River. The weir is a broadcrested weir 
located at river chainage 28550. The width is 2 m and the sill level is 31.5 m AOD. 

5.8.1 Change branch type 

To include a structure in the model, the river branch type for Karup River will first have to 
be changed to a regular branch and a dynamic solution to be able to account for back 
water effects. The upstream tributaries (all the other branches) can be kept as routing 
branches: 
 
• Select River network-> Branches and change Branch Type from Routing to Regular 

for Karup River in the Map view 

• Go to Routing Method and delete Karup River by selecting the branch and then 

clicking  Delete 

• Check the wave approximation method in Simulation specification->Computational 
control parameters. Set the method to Dynamic (default) 

• Go to Time step control and change the time step length to 5 minutes 

• Save the model and run the model to ensure that the model is numerically stable 

5.8.2 Add the weir dimensions 

A number of different weir formulations are available: Broad Crested, Villemonte Formula, 
Honma Formula and Extended Honman Formula. 
 
The geometry for broad crested weirs can be defined in two different ways:  
• Level-Width: The weir geometry is specified as levels (relative to the datum) and 

corresponding flow widths.  

• Cross Section DB: The weir geometry is specified as a cross section in the cross 
section editor. A cross section with a matching branch name, Topo ID and chainage 
must exist in the applied cross section file. 

Note: Since a weir is defined as a structure causing a contraction loss and subsequently 
an expansion loss, the geometry of the weir must be such that the cross sectional area at 
the weir is less than the cross sectional area at both the upstream and the downstream 
cross section for all water levels. 
 
You can now add the weir. In this exercise, the weir geometry uses the Level-Width 
option: 
 
• Go to River Network->Structures and select Weirs->Tabular view 

• On the General tab click  to add the weir and change the ID to Karup_spill 

• Change the Branch to Karup River and set the chainage to 28850 

• Leave the Type and Weir type unchanged 

• Under Geometry select Level-Width (default) and set the Datum (sill level) to 31.5. 
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•  Specify the weir dimensions by clicking  adding two lines: 

- Level=0, Width = 2 
- Level=10, Width = 2 
 

 
• To check the location of the weir in relation to cross sections go to the Map view. The 

location of the weir is shown as a white square. 

There is a cross-section 50 m below the weir but none upstream of the weir. As survey 
data is not available upstream of the weir, you can create a copy of the downstream cross 
section at chainage 28600 and add it upstream of the weir: 
 
• Go to River network->Cross sections and right click on the cross section in Map view  

• Select copy and specify a chainage of 28500 

• Then, save the setup 
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• Go back to the Weir menu and select Flow conditions in the Tabular view.  

• Click Calculate Q/h relations 

5.9 Re-run the model 

To look at the effects of the weir the model will need to be re-run and the results loaded 
into Mike View.  
 
• Run the model by selecting Run->Simulation from the main menu 

• Inspect the run messages on the Simulation pane and make sure the model run 
finished without errors 

• Re-open Mike View and load the results for Karup1.res1D  

• Click  and select Karup River. Press the Ctrl key and click in the view to complete 
the cross sectional plot. Select Data type = Water level 

Note: The Maximum dx = 5000 m specified in the Simulations specifications->Comp 
control parameters on the Grid spacing tab is now used for the Karup River branch. 
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6 Application Example: Impact of Groundwater Pumping 

This exercise shows how groundwater pumping affects groundwater levels and stream 
flow. The model is based on the MIKE SHE model for Karup developed in the first 
exercise. If you have completed the first exercise, you can use your own model.  
 
Otherwise, if you want to use an existing model, ensure that you have installed the 
Example files in the previous Getting Started exercise, and have opened the MIKE SHE 
exercises.mzp project file. Then, 
 
• Go to the project folder Karup_Basic  and open Karup_basic.she  

In either case,  
• Rename and save the model using the File/Save As… command to another name. 

From now on in the exercise, we will refer to this model as YourFilename.she 

6.1 Set up a new base case scenario 

First, we need to setup and run a new model without groundwater pumping so we can 
compare the results when we turn on the pumping. 

6.1.1 Redefine the horizontal grid resolution 

To analyse the effects of an abstraction we need to refine the grid.  
 
A very powerful feature of MIKE SHE is that you can change the horizontal grid without 
redefining your model parameters. Consequently you can perform sensitivity analysis of 
your model grid and grid resolution in a way that is impossible with most other modelling 
user interfaces. 
 
Note: a finer grid is possible, but the simulation time will increase substantially.  
 
Demo Note: the demo version is restricted to a maximum of 70x70 cells, so you will 
not be able to pre-process or run the model with the refined grid but can continue 
with the 500m grid. 
 
In the Model Domain and Grid Dialog of the Setup tab: 
 
• Double the number of grid cells in the X and Y directions  

• Set NX = 130 and NY = 140  

• Change the Cell Size to 250 m 
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• To ensure the model data can be converted to 250 m click on the  icon on the 
main menu to start the pre-processor. 

• Verify in the pre-processor tab that all of the input data has been converted to a 
250m grid 

Note: a number of warnings may appear as values are missing in some locations along 
the boundary. The pre-processor automatically fills in the gaps with neighbouring values.  

6.1.2 Add a new stream flow observation 

Add a new stream observation location so that you can observe the impact of abstraction 
on the local stream flow.  
 
• Go to Storing of results on the left pane and select Detailed M11 timeseries output 

• Click the add button  to add a new line 

• Specify the Name= Pindsobro and change the Data type to Discharge 

• Type in the Branch name=Karup River and set the Chainage to 18237.5 m 
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The specified Chainage needs to be at or close to the location of a MIKE HYDRO river 
computational discharge point. The pre-processor will check the distance and if it is 
greater than a prescribed tolerance a Warning will be written in the log file. 

6.1.3 Add a new groundwater observation  

Add a new groundwater observation location so that you can observe the impact of 
abstraction on the local groundwater level.  
 
• Go to Storing of results on the left pane and select Detailed timeseries output 

• Click the add button  to add a new line 

• Specify the Name= Obh_Pindsobro and change the Data type to Head elevation in 
saturated zone 

• Type in the coordinates X=513950 and Y=6230800 and Depth=5 m 
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6.1.4 Run the simulation 

For this example the simulation period will be reduced to one year, as run times will 
otherwise be too long: 
• In the Simulation period menu specify the Start date and End date: 

-  Start Date: 1 January 2000 
-  End Date: 31 December 2000 

• On the Toolbar, click on the  icon to re-run the Pre-processor and then on the 

Water Movement  icon to run the simulation 

• Click OK 
 
Note if the simulation is taking too long it can be stopped by clicking the red button below. 

 

 
 
• Check the model run log files to ensure the model finished without any errors.  

• Go to the results folder Result\Yourfilename.she - Result Files and double click on 
YourFilename_WM_Print.log 

• Scroll to the bottom of the file and check whether the different model components 
converged. Likely some of the components will have exceeded the maximum number 
of iterations. The impact of this can be evaluated later with the water balance tool. 

6.1.5 Check the stream flow and observation borehole time series plots 

After successfully running the model: 
• Click on the Results Tab located at the bottom of the Navigation Tree and select 

Simulation Results->MIKE 11 Detailed Time Series 

• Click Plot no. 2 to ensure the stream flow plot has been generated and looks 
reasonable 

Do the same for the groundwater observation borehole: 
• Click on the Results Tab located at the bottom of the Navigation Tree and select 

Simulation Results->MIKE SHE Detailed Time Series 

• Click Plot no. 5 to ensure the observation borehole plot has been generated and 
looks reasonable  
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6.2 Create a pumping scenario 

Before adding the pumping well, you need to create another scenario setup so that the 
model results can be compared.  
 
• Rename and save the model using the Save As… command: 

YourFilename_abs.she 

The river results will also change, so we also want to create another MIKE HYDRO setup: 

• Go to the Rivers and Lakes menu on the left pane and click the  button. This 
will open the MIKE Hydro editor. 

• Select Result specifications at the bottom of the left pane click on the Standard 
results tab 

• Change the HD result file name to KARUP_abs.res1d 

• Click File->Save as.. on the main menu and save the file as karup_II_abs.mhydro 

• Go back to the MIKE SHE Rivers and Lakes menu and use the browse button  
to select the new file 

 
 

On the Toolbar, click on the  icon to re-run the Pre-processor to ensure that the model 
setup is correct.  
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6.3 Add the groundwater abstraction 

In this step, use the Well Editor to add a well beside the stream.  
• First go to the Saturated zone data tree item to include abstractions and tick Include 

pumping wells 

• A new item in the data tree, Pumping Wells, will now appear below Drainage. 

• Select Pumping Wells and click the button  to create a new well database 
file. This will open the Well Editor in a new window 

• Browse to the folder .\Model Inputs and name the file MyWells.wel. Click Save 

 
 

• To open the database file click . This will open a new window with the 
empty database file 

The new file automatically shows a map of the catchment outline and the background 
map specified in the Display menu. The overlays are carried over from the model Setup 
Tab. You cannot add or modify overlays directly in the Well Editor. This must be done 
from the Setup Tab. Right clicking on the map, allows you to control the zoom and a 
number of other functions. The interactive map displays all of the wells in the well file. 
Clicking on individual wells will select the corresponding item in the table of well locations. 
Similarly, selecting an item from the list will change the icon of the well on the map to a 
red square. 
 
To add a new well,  

• Click the button  to add a new line under Well locations. Then update the line:  
- Name = Pindsobro 
- Xcoor = 513900,  
- Ycoor = 6230750,  
- Level = 62 m and  
- Depth = 60 m. 

• Next, in the Filter table, click the add button  and add the filter settings:  
- Top = 25 m and  
- Bottom = 15 m 
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You can see the location of the well on the map view, and the well screen in relation to 
the geological layers and lenses, as well as the numerical grid layers.  
 
• To specify the abstraction rate, click the browse button  and select abs.dfs0 and 

select Item: Pindsobro. Click OK  

 
 
• To view the abstraction rate click the edit button . Inspect the .dfs0 file  

• Close the abstraction time series file 

From the Toolbar at the top and Import it also is possible to import well data from a tab 
delimited ASCII file:  
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Note: Zeus data is a specialized data format from the Geological Survey of Denmark and 
Greenland.  
 
• Save and close the well file 

• To view a map showing the location of the abstraction in the MIKE SHE file tick Show 
well location map 

6.4 Run the pumping simulation 

Before running the simulation, we need to add the results from the original scenario as 
observations in the pumping scenario.  

6.4.1 Add the stream flow result file 

To see the difference in stream flow with and without abstraction in the MIKE SHE menu 
system, add the result file from the model run without the abstraction to the stream plot at 
Pindsobro: 
 
• Go to Storing of results on the left pane and select Detailed M11 timeseries output 

• On the second line tick Incl. Obs. Data 

• Click the browse button  and find your detailed time series results for the 
previous simulation without the abstraction:  
YourFilename_DetailedTS_M11.dfs0 
 

• Before closing the Selection dialog, under Items select Pindsobro 

• Click OK 

6.4.2 Add the head result file 

To see the drawdown caused by the abstraction, you can add the result file from the 
model run without abstraction to the head elevation plot at Pindsobro.  
 
• Go to Storing of results on the left pane and select Detailed timeseries output 

• On the second line tick Incl. Obs. Data 

• Click the browse button  and find your detailed time series results for the 
previous simulation without the abstraction:  
YourFilename_DetailedTS_SZ.dfs0 

• Under Items select Obh_Pindsobro 

• Click OK 
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Adding time series of modelled heads from another model run can be done in two 
different ways, depending on whether observation data is available.  
1. In the first case where no observation data is available, you can add the previous 

results as observations.  
2. Alternatively, you can add a new line below the results item and unclick the New plot 

checkbox. This way it is possible to add both observation data and multiple 
simulation results to the same graph. This may be useful during calibration where 
you want to compare the results from more than one run to the observations. 

6.4.3 Run the simulation 

On the Toolbar, click on the  icon to re-run the Pre-processor and then on the Water 

Movement  icon to run the simulation 
 
When the model is finished, check the log file to ensure the model finished without any 
errors: YourFilename_abs_WM_Print.log 

6.5 Analyze the change in stream flow  

6.5.1 View the detailed time series output results  

To view the stream flow at Pindsobro click on the Results tab at the bottom of the menu 
and then Simulation Results->MIKE 11 Detailed Time Series 
 
The black line shows the discharge at Pindsobro for the current model run without the 
abstraction compared with the results from the model run including the abstraction 
(plotted as observation points). It is clear that the abstraction is having a large impact on 
stream flows all year round due to the vicinity of the well to the stream and high 
connectivity between the stream and aquifer. 
 

 
 
• To view the groundwater level close to the Pindsobro abstraction click on go to the 

MIKE SHE Detailed Time Series, Plot no 5 
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The graph shows a significant drawdown in head due to the abstraction. 
 

  

6.5.2 Calculate the difference in the stream flow  

To calculate the difference in flow at Pindsobro without and with pumping: 
 
• Open the YourFilename_DetailedTS_M11.dfs0 in the results file folder for the 

refined (250m) model without abstraction:  

• Click Edit->Properties in the top Menu 

• Add two new lines to the table by clicking on the  button and update the 
new lines as follows:  

. 
• Click OK 

• From the top Menu, use File->Save as.. and save the file as Q_diff.dfs0 

Now, 
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• Open the YourFilename_abs_Detailed_TS_M11.dfs0 in the results file folder for 
the refined (250m) model with abstraction:  

• Select the second column named Pindsobro and copy the data to the clip board (^C) 

• Return to your Q_diff.dfs0 file and paste (^V) the data in the third column  

• Save the file 

Now, you need to use the functions option in the Time Series Editor to calculate the 
difference in flow between the two columns:  

•  click  on the toolbar at the top 

• Type in the Current Expression textbox: i4=i2-i3 

 
 
• Click OK and save file 

This should immediately fill in the fourth column with the difference between Column 2 
and 3.  
 
 
 
 



 MIKE SHE 

108 Fully Integrated Exercises - © DHI 

6.5.3 Use the Plot Composer to plot the impact on stream flow  

To plot the flows and the differences using the Plot Composer tool: 
 
• Create a new Plot Composer document from File/New in the top menu or use the 

New File icon, and then select the Plot Composer icon in the list of MIKE Zero 
documents. 

• Insert a new plot using either Plot->Insert New Plot Object and select Time Series 

Plot or by clicking on the New Plot icon, , and selecting the Time Series Plot 

• In the Properties dialog that appears, click New Item  and select your 
Q_diff.dfs0 from the list 

• Under Any Item Type select Pindsobro, Pindsobro_abs and Diff_Pindsobro  

• Click OK 

 
 
• To change the appearance of the graphs, right click on the graphs and select 

Properties. Click Curves and change line colours and markers 

• To save the graph as an image click View->Export Graphics->Save to Bitmap 

• Save the plot composer file as Q_diff.plc in the Model folder 

You should get a plot something like this:  
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6.5.4 Use MIKE View to calculate the change in stream flow accretion 

We want to look at the effect of the pumping on stream flow accretion along the Karup 
River at different times. To do this: 
 
• Use Windows Explorer to navigate to the results folder for the MIKE Hydro simulation 

with abstraction, and then double click on the file: KARUP_abs.res1d 

• Click OK to load all the data 

This should open the MIKE HYDRO result file in MIKE View. If for some reason this does 
not work, you can also open MIKE View from the Program menu and load the file. If the 
file is not yet loaded,   
• add the MIKE Hydro result file (*.res1d) abstraction to MIKE View using the File/Add 

in the top menu. 
• Click OK to load the result file 
 
Once MIKE View is open, with the results loaded, we want to plot the stream flow 
accretion with and without pumping. To do this:  

• Click the profile button  on the main menu to draw a profile 

• Click on the middle branch of Karup stream (the branch turns green), press the Ctrl 
key, click in the view, and select ‘Yes’ to create the longitudinal plot.  

• Select Data Type=Discharge, and click OK 
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Now, to add the no-pumping MIKE Hydro *.res1D  
• Click on the Options icon 

  
 
• Select the Graphical Items tab 

• Click the Add button . Then select Dynamic Item, File= Karup_nat.res1d (your 
file without pumping) and Item=Discharge. Then click OK.  

  
• You may want to chose a different line colour etc, change the Actual name, etc. Then 

click OK 
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To save the plot layout, right-click on the map view and select Save complete layout.  

• Save the file as Stream_flow_acc.CLA 

You can then reload this file in future to recreate the plot.  
 
• To re-load the file click File->Reload complete layout…and select 

Stream_flow_acc.CLA located in .\Result 

• Click OK and OK to load the MIKE HYDRO result files 
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6.6 Analyze the well drawdown 

To evaluate the radius of influence of the well, we can looking at the well drawdown in 
space and time. To do this we need to subtract the no-pumping results from the pumping 
results. There are basically two ways to do this.  
 
• Grid Editor - The most direct way is to subtract the files from within the Grid Editor 

• Grid Calculator - However, if you want to do this regularly, say at the end of every 
simulation you can set up a script using the Grid Calculator Tool in the MIKE SHE 
Toolbox.  

6.6.1 Calculate drawdown using the Grid Editor 

To calculate the difference in groundwater levels at Pindsobro without and with pumping: 
 
• Open the YourFilename_3DSZ.dfs3 in your Results directory, and save the file to a 

new name (eg Drawdown.dfs3) using the File/Save as… menu function. 

Demo note: in Demo mode, you will not be able to save any changes to the 
dfs3 file 
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Now, to subtract the two results files:  
  
• Click Tools->Copy File into Data on the main menu 

 
 

• Select the File to Copy using the browse button , and find your no-pumping 
_3DSZ.dfs3 results file  

• Under Operation Type: choose the minus sign, “–“ 

• Click OK, and then Yes to continue 

 
 
This process will change every value in every time step, by subtracting the two values. 
The result will be a dfs3 containing only the differences.  
 
 
 
 
 



 MIKE SHE 

114 Fully Integrated Exercises - © DHI 

You can view the new values by  
 

• Clicking on the  Time Step Forward and Backwards buttons  to view the 
drawdown at different times 

• Zoom in by right clicking on the map 

 
 
MIKE SHE includes sophisticated tools for managing gridded data as well as time series 
data. This is very useful for time varying distributed parameters, such as precipitation that 
is interpolated from rain gauge data, or distributed recharge calculated by third party 
programs. 
 
• The grid editor is a split window that can be dragged sideways to make the map 

smaller or larger. The table of values on the right side reflects the highlighted grid 
shown on the map.  

• Ranges of values can be searched for, selected and changed using the select and 

unselect tools, , plus the Tools/Set Value… Dialog. 

Important Note 
The grid editor is a generic grid tool for all DHI Software, and was originally developed for 
the Marine programs MIKE 21 and MIKE 3. However, this often leads to confusion in the 
node and layer numbering because MIKE 21 and MIKE 3 use a different numbering 
system.  
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Node numbering: In the Grid Editor (and in MIKE 21 and MIKE 3) the nodes are 
numbered starting in the lower left from (0,0), whereas in the MIKE SHE dialogs and log 
files the nodes are numbered starting in the lower left from (1,1). 
 
Layer numbering: In the Grid Editor (and in MIKE 21 and MIKE 3) the layers are 
numbered starting at the bottom from 0, whereas in the MIKE SHE dialogs and log files 
the layers are numbered starting at the top from 1. 
 

6.6.2 Calculate Drawdown with the Grid Calculator 

. To make this conversion, you can:  
 
• Click on the New File icon, or the File/New/File… top menu. Then select the MIKE 

SHE toolbox. 

 
 
• Now select Util/Grid Calculator  

 
 

• Add a title if you want and then click   
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In the Calculation Setup dialog that appears: 

 
 
• Browse to the two dfs3 head results files (pumping and no pumping) and add them to 

the list of items with a Variable name of A and B. Note that you will need to change 
the Files of type to Grid series files (.dfs3). And, you will need to select the Item Type 
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• Add a Description, if you like, and a Filename, such as drawdown.dfs3 

• Select the Item type = Water Depth, with a Item Unit = meter 

• Now set up the Expression “A-B”. Note that the variable names are case sensitive 

• Then, click   

• On the last page, click  to run the actual conversion.  

• Click OK in the window saying successful completion 

• Click  to close the tool.  

The Grid Calculator is a very useful tool. It allows you to do complex, multi-step, 
operations on files. It also has limited statistical functions, as well as a Group function. 
Together these allow you to create sophisticated analyses, such as the minimum monthly 
water levels over your simulation, or the number of days that are area is flooded per year.  
 
You can also save the Toolbox tool and run it at the end of your simulation. You can also 
run the Grid Calculator from a command prompt or batch file directly.  

6.6.3 Plot the drawdown using the Plot Composer 

You can look at the drawdown in the Grid Editor, but if you want to create a report plot, 
you can use Plot Composer.  
 
However, the Plot Composer does not support dfs3 files. Therefore, first you need to 
convert the drawdown file from a .dfs3 file to a .dfs2 file. To make this conversion, you 
can:  
 
• Click on the New File icon, or the File/New/File… top menu. Then select the MIKE 

ZERO toolbox 
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• Now select Extraction/2D Grid from 3D files  

 
 

• Add a title if you want and then click   

• Browse to your Drawdown.dfs3 file and click   

• Click  again for all time steps, and click  again for the default 
layer 

• Specify a File Name and Title for the output file (eg Drawdown.dfs2). Then, click 

  

• On the last page, click  to run the actual conversion.  

• Click OK in the window saying successful completion 

• Click  to close the tool.  

If you save the tool setup, then you can run it again without having to update it. You can 
also run a saved toolbox setup from a batch file.  

 
Now open a new Plot Composer document to create a drawdown map as you did before.  
 
• Click Plot->Insert New Plot Object and select Grid Plot 

• In the Grid Plot Properties menu select the Master File as Drawdown.dfs2 

• Select the Contours menu 

• Tick With labels and tick Plot color Legend 

• Click OK 

• To view the drawdown at different times first select the Animate menu at the bottom 

left  

• Use the play menu  to move through the file 

• To change the colours or layout go back to the  menu and right click on the 
map. Select Properties. Play with the colour scale. 

• To add the stream to the map right click on the map and select Add/Remove 
layers…. 

• Click the add button  to add a new item 
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• Change File type to Shapefile and in .\Model Inputs\GIS data select 
karup_georef.shp 

• Click  

• To save the graph as an image click View->Export Graphics->Save to Bitmap 

• Click File->Save as.. and save the file as Drawdown.plc 
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6.7 Analyze the change in water balance 

You can use the water balance tool to look at the impact of the abstraction. 

6.7.1 Create a new water balance document 

• Click on the New document icon, , or the File/New/File menu 

• Select MIKE SHE and then the Water Balance Calculation (.wbl) document  

 
 

• Click OK 

• In the Project Explorer select the directory where you want to save the document 

• Then give the file a name (e.g. Waterbalance) and click on the Save icon  

6.7.2 Extract the water balance data 

• Use the browse button and find the .sheres file from your simulation in your Result 
directory  

• Run the water balance extraction by clicking on the Extraction icon,  or by 
selecting the drop down window Run and clicking on Extraction.  

• Check to make sure that the Extraction ran successfully, by looking for “Normal 
termination” in the message window 

6.7.3 Define a Chart water balance 

• As there will only be only item it is not ncessary to add more items on the 
Postprocessing tab 

• Select Chart output: Total water balance from the list of available Water balance 
types.  

• Define a file name for the output file, for example Water_balance_abs.txt  
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• Run the water balance by clicking on the water balance icon run selected 

postprocessing,  

 
 
The Chart output creates a graphic illustrating the water balance items (see next step). 
The output is sent to an ASCII .txt file, and the graphic is generated automatically by a 
utility that reads the txt file.  
 
By default, the water balance is summed for the entire simulation period. However, you 
can easily change the water balance period, for example, to create seasonal water 
balances, or to remove the initialisation period.  
 
If you defined the extraction on a sub-catchment basis, then you can select from the 
available sub-catchments in this Dialog.  
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6.7.4 View the water balance output 

• On the Result tab, select the sub-item for the Chart output 

• Click on the Open button beside the file path to create and open the water balance 
graphic 

• To compare the water balance with abstraction to that without abstraction repeat the 
same procedure for the model run without abstraction 
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The water balances show that during the simulation period  a total of 14 mm is abstracted. 
7 mm is taken from saturated storage (storage change) and the remainder causes a 
reduction in baseflow of 1 mm and drain flow of 6 mm compared to natural conditions. 
 
Additional optional exercise: Play around with the different water balance options to 
see how baseflow, drain flow and saturated zone storage may be changing over time due 
to abstraction. 
 
Note that the water balance items are all normalised to units of mm, which allows for easy 
comparison between the different components. If you want to convert depths of mm to 
volumes, you need to multiply the depth by the internal model area. That is, the total 
model area minus the area of the outer boundary cells.  
 
An easy way to calculate the internal model area is to load the pre-processed data into 
the Grid Editor, select the Model and Domain item. Then, you can use the statistics 
function in the Grid Editor to find out the number of internal (Grid Code = 1) versus 
boundary cells (Grid Code = 2). 
 

End of the Exercise 


